summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1077ad03c2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = clustalw
+ pkgdesc = Clustal W multiple sequence alignment program, version 2.0
+ pkgver = 2.1
+ pkgrel = 3
+ url = http://www.clustal.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = glibc
+ depends = gcc-libs
+ provides = clustalw2
+ source = http://www.clustal.org/download/current/clustalw-2.1.tar.gz
+ md5sums = 144df8440a0ae083d5167616c8ceeb41
+
+pkgname = clustalw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25707d02563f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributer: machoo02 <ichthyoboy at gmail dot com>
+
+pkgname=clustalw
+pkgver=2.1
+pkgrel=3
+pkgdesc="Clustal W multiple sequence alignment program, version 2.0"
+arch=('i686' 'x86_64')
+provides=('clustalw2')
+url="http://www.clustal.org"
+license=('GPL3')
+depends=('glibc' 'gcc-libs')
+source=(${url}/download/current/${pkgname}-${pkgver}.tar.gz)
+md5sums=('144df8440a0ae083d5167616c8ceeb41')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+