summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 31 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d966c8a79e0..75a21fcbb92d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 7 23:17:06 UTC 2017
pkgbase = clutter-git
- pkgdesc = A GObject based library for creating fast, visually rich graphical user interfaces
- pkgver = 1.24.2.r17.g8c86357
+ pkgdesc = A toolkit for creating fast, portable, compelling dynamic UIs
+ pkgver = 1.26.0.r28.g55093e304
pkgrel = 1
url = http://clutter-project.org/
arch = i686
arch = x86_64
license = LGPL
makedepends = git
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ depends = gtk3
depends = cogl
- depends = mesa
- depends = json-glib
- depends = atk
- depends = libxi
- depends = gtk-doc
depends = libinput
- depends = gobject-introspection
- depends = libxkbcommon
- provides = clutter=1.24.2.r17.g8c86357
+ provides = clutter=1.26.0.r28.g55093e304
conflicts = clutter
source = git://git.gnome.org/clutter
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f6eb2dd4463e..e558bb0c0927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,44 @@
# Contributor: alesko <askondro@gmail.com>
pkgname=clutter-git
-pkgver=1.24.2.r17.g8c86357
+pkgver=1.26.0.r28.g55093e304
pkgrel=1
-pkgdesc='A GObject based library for creating fast, visually rich graphical user interfaces'
+pkgdesc="A toolkit for creating fast, portable, compelling dynamic UIs"
arch=('i686' 'x86_64')
url='http://clutter-project.org/'
license=('LGPL')
-depends=('cogl' 'mesa' 'json-glib' 'atk' 'libxi' 'gtk-doc' 'libinput' 'gobject-introspection' 'libxkbcommon')
-makedepends=('git')
+depends=('gtk3' 'cogl' 'libinput')
+makedepends=('git' 'gobject-introspection' 'gtk-doc')
provides=("clutter=${pkgver}")
conflicts=('clutter')
source=('git://git.gnome.org/clutter')
md5sums=('SKIP')
pkgver() {
- cd clutter
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd clutter
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd clutter
+ cd clutter
- ./autogen.sh --prefix=/usr --enable-introspection \
- --enable-wayland-backend --enable-egl-backend --enable-evdev-input \
- --enable-wayland-compositor
- make
+ ./autogen.sh --prefix=/usr \
+ --enable-introspection \
+ --enable-egl-backend \
+ --enable-gdk-backend \
+ --enable-wayland-backend \
+ --enable-x11-backend \
+ --enable-evdev-input \
+ --enable-wayland-compositor \
+ --enable-gtk-doc
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
}
package() {
- cd clutter
- make DESTDIR=$pkgdir install
+ cd clutter
+ make DESTDIR="$pkgdir" install
}