summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23090eba69ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Sat Jun 13 06:55:12 UTC 2015
+pkgbase = cmake-lint
+ pkgdesc = Check for coding style issues in CMake files
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://github.com/richq/cmake-lint/
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/richq/cmake-lint/archive/v1.3.1.tar.gz
+ md5sums = 0c333de7351e2fc72a4a7bb247ed6712
+
+pkgname = cmake-lint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a1fe14d480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=cmake-lint
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Check for coding style issues in CMake files"
+arch=('any')
+url="http://github.com/richq/cmake-lint/"
+license=('APACHE')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/richq/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0c333de7351e2fc72a4a7bb247ed6712')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python ./setup.py install --prefix=/usr --root="$pkgdir"
+}