summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 237be02b3f90..ed14c9efe108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cni-bin
pkgdesc = Standardised container networking interface
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.cni.dev/
arch = x86_64
arch = aarch64
@@ -10,6 +10,7 @@ pkgbase = cni-bin
license = apache
provides = cni=1.0.1
conflicts = cni
+ conflicts = cni-plugins
source = cni-bin-1.0.1::https://github.com/containernetworking/plugins/releases/download/v1.0.1/cni-plugins-linux-amd64-v1.0.1.tgz
sha256sums = 5238fbb2767cbf6aae736ad97a7aa29167525dcd405196dfbc064672a730d3cf
diff --git a/PKGBUILD b/PKGBUILD
index 1a6a4e8bc7e6..34a919d46db5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=cni-bin
pkgdesc="Standardised container networking interface"
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
url="https://www.cni.dev/"
license=('apache')
-conflicts=('cni')
+conflicts=('cni' 'cni-plugins')
provides=("cni=${pkgver}")
source=()
sha256sums=()
@@ -34,4 +34,6 @@ package() {
install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."
# also deposit bins in alternate possible location
install -Dm755 "${srcdir}/"* "${pkgdir}/usr/lib/cni"
+ # please ensure kubelet args point to one of these two directories preferably the first
+ # I.E the file `/etc/kubernetes/kubelet.env` should contain something like: KUBELET_ARGS=--cni-bin-dir=/opt/cni/bin
}