summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.NVCHECKER7
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
3 files changed, 52 insertions, 18 deletions
diff --git a/.NVCHECKER b/.NVCHECKER
new file mode 100644
index 000000000000..7ccd14da3325
--- /dev/null
+++ b/.NVCHECKER
@@ -0,0 +1,7 @@
+[cni-plugins]
+source = "github"
+github = "containernetworking/plugins"
+prefix = "v"
+use_max_tag = true
+exclude_regex = ".(release|weekly|rc|alpha|beta)."
+
diff --git a/.SRCINFO b/.SRCINFO
index 5931a6294805..47d0f14116f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = cni-plugins-bin
- pkgdesc = Some CNI network plugins, maintained by the containernetworking team
- pkgver = 0.8.1
+ pkgdesc = Container Networking Interface (CNI) Plugins
+ pkgver = 1.4.1
pkgrel = 1
- url = https://github.com/containernetworking/plugins
+ url = https://www.cni.dev/
arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv7l
license = Apache
- source = https://github.com/containernetworking/plugins/releases/download/v0.8.1/cni-plugins-linux-amd64-v0.8.1.tgz
- sha256sums = e9bfc78acd3ae71be77eb8f3e890cc9078a33cc3797703b8ff2fc3077a232252
+ provides = cni-plugins=1.4.1
+ conflicts = cni-plugins
+ source = cni-plugins-bin-1.4.1-amd64::https://github.com/containernetworking/plugins/releases/download/v1.4.1/cni-plugins-linux-amd64-v1.4.1.tgz
+ b2sums = 6c3ac57dfbff150bea1917bdb2cecd88604018f904d378927a1d14ea53fe1bcea2274f3b91cd3998c05cc596f877a77f6253c3a93c309516bc5671f54025bc94
pkgname = cni-plugins-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 0ab9a020aea5..0168c51b0631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,42 @@
-# Maintainer: ProFfeSsoRr <evvsoft at gmail dot com>
+# Maintainer: GeorgeRaven <GeorgeRavenCommunity at pm dot me>
+# Contributor: ProFfeSsoRr <evvsoft at gmail dot com>
pkgname=cni-plugins-bin
-pkgver=0.8.1
+pkgdesc="Container Networking Interface (CNI) Plugins"
+pkgver=1.4.1 # renovate: datasource=github-tags depName=containernetworking/plugins
pkgrel=1
-pkgdesc="Some CNI network plugins, maintained by the containernetworking team"
-arch=(x86_64)
-url="https://github.com/containernetworking/plugins"
+arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
+url="https://www.cni.dev/"
license=('Apache')
-source=("https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-amd64-v${pkgver}.tgz")
-sha256sums=('e9bfc78acd3ae71be77eb8f3e890cc9078a33cc3797703b8ff2fc3077a232252')
+conflicts=('cni-plugins')
+provides=("cni-plugins=${pkgver}")
+source=()
+b2sums=('6c3ac57dfbff150bea1917bdb2cecd88604018f904d378927a1d14ea53fe1bcea2274f3b91cd3998c05cc596f877a77f6253c3a93c309516bc5671f54025bc94')
+
+# if CARCH is not set default to x86_64
+# https://stackoverflow.com/a/11362364/11164973
+: "${CARCH:=x86_64}"
+
+case "$CARCH" in
+ arm*) _pkgarch="arm"
+ ;;
+ aarch64) _pkgarch="arm64"
+ ;;
+ x86_64) _pkgarch="amd64"
+ ;;
+esac
+
+source+=(${pkgname}-${pkgver}-${_pkgarch}::"https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-${_pkgarch}-v${pkgver}.tgz")
package() {
- cd "$srcdir"
- mkdir -p "$pkgdir"/opt/cni/bin
- install -Dm755 * "$pkgdir"/opt/cni/bin
- rm "$pkgdir"/opt/cni/bin/cni-plugins-linux-amd64-v${pkgver}.tgz
+ cd "${srcdir}"
+ # get rid of unwanted link
+ unlink "${pkgname}-${pkgver}-${_pkgarch}"
+ # install to default location
+ mkdir -p "${pkgdir}/opt/cni/bin" "${pkgdir}/usr/lib/cni"
+ install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."
+ # also deposit bins in alternate possible location
+ install -Dm755 "${srcdir}/"* "${pkgdir}/usr/lib/cni"
+ # please ensure kubelet args point to one of these two directories preferably the first
+ # I.E the file `/etc/kubernetes/kubelet.env` should contain something like: KUBELET_ARGS=--cni-bin-dir=/opt/cni/bin
}
-