summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c51f7715b2f..08721d5d7ffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cni-plugins-bin
pkgdesc = Container Networking Interface (CNI) Plugins
- pkgver = 1.0.1
+ pkgver = 1.1.1
pkgrel = 2
url = https://www.cni.dev/
arch = x86_64
@@ -8,9 +8,9 @@ pkgbase = cni-plugins-bin
arch = armv7h
arch = armv7l
license = Apache
- provides = cni-plugins=1.0.1
+ provides = cni-plugins=1.1.1
conflicts = cni-plugins
- source = cni-plugins-bin-1.0.1::https://github.com/containernetworking/plugins/releases/download/v1.0.1/cni-plugins-linux-amd64-v1.0.1.tgz
- sha256sums = 5238fbb2767cbf6aae736ad97a7aa29167525dcd405196dfbc064672a730d3cf
+ source = cni-plugins-bin-1.1.1-amd64::https://github.com/containernetworking/plugins/releases/download/v1.1.1/cni-plugins-linux-amd64-v1.1.1.tgz
+ b2sums = e810719c7f6db63bf0e17ee27cd50b23e3bfcfedc4e889b0bcc5ef146f01a4ccda123a7c16e57d9af951970ecc9604def2968ad8136113e06459da968529b66f
pkgname = cni-plugins-bin
diff --git a/PKGBUILD b/PKGBUILD
index d25f666b1849..6324acce50b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: GeorgeRaven <GeorgeRavenCommunity at pm dot me>
# Contributor: ProFfeSsoRr <evvsoft at gmail dot com>
+
pkgname=cni-plugins-bin
pkgdesc="Container Networking Interface (CNI) Plugins"
-pkgver=1.0.1
+pkgver=1.1.1
pkgrel=2
arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
url="https://www.cni.dev/"
@@ -10,26 +11,26 @@ license=('Apache')
conflicts=('cni-plugins')
provides=("cni-plugins=${pkgver}")
source=()
-sha256sums=()
+b2sums=()
case "$CARCH" in
arm*) _pkgarch="arm"
- sha256sums+=('d35e3e9fd71687fc7e165f7dc7b1e35654b8012995bbfd937946b0681926d62d')
+ b2sums+=('dc72e98e4b527521228d012a60a0bada8fd4aa57fb8688b5d2c3d5e132b5c5b6d942ae88d397dcd36d52cedf1d18603d6865b133923da078dca0d4c3ae4a4114')
;;
aarch64) _pkgarch="arm64"
- sha256sums+=('2d4528c45bdd0a8875f849a75082bc4eafe95cb61f9bcc10a6db38a031f67226')
+ b2sums+=('bbe31627c82c1d5b2093c5cee23f3a28de8b6384d1952524c2565e3e1fc3bbe47df7bb10363c73ea11acf32ebfd75aa3a435c0c2ef5b731167c7f2e6c47ad4c2')
;;
x86_64) _pkgarch="amd64"
- sha256sums+=('5238fbb2767cbf6aae736ad97a7aa29167525dcd405196dfbc064672a730d3cf')
+ b2sums+=('e810719c7f6db63bf0e17ee27cd50b23e3bfcfedc4e889b0bcc5ef146f01a4ccda123a7c16e57d9af951970ecc9604def2968ad8136113e06459da968529b66f')
;;
esac
-source+=(${pkgname}-${pkgver}::"https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-${_pkgarch}-v${pkgver}.tgz")
+source+=(${pkgname}-${pkgver}-${_pkgarch}::"https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-${_pkgarch}-v${pkgver}.tgz")
package() {
cd "${srcdir}"
# get rid of unwanted link
- unlink "${pkgname}-${pkgver}"
+ unlink "${pkgname}-${pkgver}-${_pkgarch}"
# install to default location
mkdir -p "${pkgdir}/opt/cni/bin" "${pkgdir}/usr/lib/cni"
install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."