summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 20 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80011c6d08a3..0ccf135777d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Jun 1 16:02:20 UTC 2016
pkgbase = coccigrep-git
- pkgdesc = coccigrep is a semantic grep for the C language based on coccinelle. Git HEAD Package version
- pkgver = v1.16.r1.g6d70e56
+ pkgdesc = Semantic grep for the C language based on coccinelle. Git version
+ pkgver = 1.20
pkgrel = 1
- url = http://http://home.regit.org/software/coccigrep/
+ url = http://home.regit.org/software/coccigrep/
arch = any
license = GPL3
makedepends = python-setuptools
- depends = python-setuptools
- provides = coccigrep
- source = git+https://github.com/regit/coccigrep.git
+ depends = coccinelle
+ provides = coccigrep=1.20
+ source = https://github.com/regit/coccigrep
md5sums = SKIP
pkgname = coccigrep-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 992bed1a7031..a7c8188cee86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,25 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
# Maintainer: orumin <dev@orum.in>
-_gitroot=coccigrep
pkgname=coccigrep-git
-provides=('coccigrep')
-conflict=('coccigrep')
-pkgver=v1.16.r1.g6d70e56
+pkgver=1.20
pkgrel=1
-pkgdesc='coccigrep is a semantic grep for the C language based on coccinelle. Git HEAD Package version'
+pkgdesc='Semantic grep for the C language based on coccinelle. Git version'
arch=('any')
-url='http://http://home.regit.org/software/coccigrep/'
+url='http://home.regit.org/software/coccigrep/'
license=('GPL3')
-depends=('python-setuptools')
+depends=('coccinelle')
makedepends=('python-setuptools')
-source=("git+https://github.com/regit/$_gitroot.git")
+source=('git+https://github.com/regit/coccigrep')
md5sums=('SKIP')
+provides=("coccigrep=${pkgver%+*}")
+conflict=('coccigrep')
pkgver() {
- cd "$_gitroot"
- git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
-}
-
-build() {
- cd "$srcdir"
+ git -C coccigrep describe --abbrev=7 --tags | sed 's/^v//; s/-/+/; s/-/./'
}
package() {
- cd "$srcdir/coccigrep"
-
+ cd coccigrep
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
-
}