summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11c43dc0311e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cockatrice-client-git
+ pkgdesc = A cross-platform virtual tabletop for multiplayer card games (Client)
+ pkgver = 20150924.1
+ pkgrel = 1
+ url = http://www.woogerworks.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = qt5-tools
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = protobuf
+ depends = zlib
+ conflicts = cockatrice-client
+ source = git+https://github.com/Cockatrice/Cockatrice.git
+ md5sums = SKIP
+
+pkgname = cockatrice-client-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e2d372fec5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jorge Araya Navarro <elcorreo@deshackra.com>
+pkgname=cockatrice-client-git
+pkgver=20150924.1
+pkgrel=1
+pkgdesc="A cross-platform virtual tabletop for multiplayer card games (Client)"
+arch=('i686' 'x86_64')
+url="http://www.woogerworks.com/"
+license=('GPL2')
+depends=('qt5-base' 'qt5-tools' 'qt5-multimedia' 'qt5-svg' 'protobuf' 'zlib')
+makedepends=('git' 'cmake')
+conflicts=('cockatrice-client')
+source=(git+https://github.com/Cockatrice/Cockatrice.git)
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/Cockatrice"
+
+ if [ ! -d "build"];
+ then
+ mkdir build
+ else
+ rm -rf build
+ mkdir build
+ fi
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DWITH_CLIENT=1 -DWITH_ORACLE=1 -DWITH_SERVER=0 ..
+ make
+}
+
+package() {
+ cd "$srcdir/Cockatrice/build"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: