summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
3 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e8b98738286..bb1053c73c72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cockatrice-server-git
pkgdesc = Open-source multiplatform supported program for playing tabletop card games over a network.
- pkgver = 2.7.5
- pkgrel = 4
+ pkgver = 2.8.1.beta.r3.gdb5f6e01
+ pkgrel = 1
url = https://cockatrice.github.io/
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = cockatrice-server-git
optdepends = mariadb: database support
provides = cockatrice-server
conflicts = cockatrice-server
- source = git+https://github.com/Cockatrice/Cockatrice
+ source = cockatrice-server-git::git+https://github.com/Cockatrice/Cockatrice
sha256sums = SKIP
pkgname = cockatrice-server-git
diff --git a/.gitignore b/.gitignore
index e0bc11c54533..43e775284e70 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
Cockatrice/
+cockatrice-server-git/
*.tar.xz
*.swp
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 5484b073d318..881d41f2d0ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Mikhail Burakov <mikhail.burakov@gmail.com>
pkgname=cockatrice-server-git
-pkgver=2.7.5
-pkgrel=4
+pkgver=2.8.1.beta.r3.gdb5f6e01
+pkgrel=1
pkgdesc='Open-source multiplatform supported program for playing tabletop card games over a network.'
arch=('i686' 'x86_64')
url='https://cockatrice.github.io/'
@@ -16,11 +16,16 @@ optdepends=('mariadb: database support')
makedepends=('cmake' 'git' 'mariadb-libs')
provides=('cockatrice-server')
conflicts=('cockatrice-server')
-source=("git+https://github.com/Cockatrice/Cockatrice")
+source=("$pkgname"::"git+https://github.com/Cockatrice/Cockatrice")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | cut -d- -f5- | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
build() {
- cd "$srcdir/Cockatrice"
+ cd "$srcdir/$pkgname"
test -d build && rm -rf build
mkdir build
cd build
@@ -29,6 +34,6 @@ build() {
}
package() {
- cd "$srcdir/Cockatrice/build"
+ cd "$srcdir/$pkgname/build"
make DESTDIR="$pkgdir/" install
}