summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
-rw-r--r--code.desktop (renamed from visual-studio-code-oss.desktop)2
-rw-r--r--product_json.patch18
-rw-r--r--visual-studio-code-oss.nonfree.install15
5 files changed, 31 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50387886decb..6b86a6c8c86c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Dec 15 18:58:53 UTC 2017
-pkgbase = visual-studio-code-oss
- pkgdesc = Visual Studio Code for Linux, Open Source version
+# Mon Dec 18 22:35:59 UTC 2017
+pkgbase = code
+ pkgdesc = Microsoft Code -- The Open Source build of Visual Studio Code
pkgver = 1.19.0
pkgrel = 1
- url = https://code.visualstudio.com/
+ url = https://github.com/Microsoft/vscode
arch = i686
arch = x86_64
arch = armv7h
@@ -24,13 +24,17 @@ pkgbase = visual-studio-code-oss
depends = nss
depends = alsa-lib
provides = vscode-oss
+ provides = visual-studio-code-oss
conflicts = vscode-oss
+ conflicts = visual-studio-code-oss
source = vscode::git+https://github.com/Microsoft/vscode#tag=1.19.0
+ source = code.desktop
source = startup_script.patch
- source = visual-studio-code-oss.desktop
+ source = product_json.patch
sha256sums = SKIP
+ sha256sums = f472fb49852ae9048966f02278110efbbe451192a8ae312ec05d1c31093a0ff4
sha256sums = 8b2feded3382e5bf6b5b292c14083bfc536c05cd00f3235dd22b75b67fba134d
- sha256sums = d140d0de9998a2a886a6d2ff23f356f8b68c8aae5a53c33ec87826e5d7ad3529
+ sha256sums = 7970996eaddbb0265373e71c5452064465472ebb5bd6a393b94e8b84bde24854
-pkgname = visual-studio-code-oss
+pkgname = code
diff --git a/PKGBUILD b/PKGBUILD
index 68898f9bf21b..a5827f86fb66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
# Maintainer: Michael Hansen <zrax0111 gmail com>
# Contributor: Francisco Magalhães <franmagneto gmail com>
-# Set this to 1 if you want to enable the proprietary Visual Studio Code
-# features. Leaving this at 0 will cause the extension manager to work in
-# a local-only mode (you'll have to download and install extensions manually).
-[[ -z "$VSCODE_NONFREE" ]] && VSCODE_NONFREE=0
-
-pkgname=visual-studio-code-oss
-pkgdesc='Visual Studio Code for Linux, Open Source version'
+pkgname=code
+pkgdesc='Microsoft Code -- The Open Source build of Visual Studio Code'
pkgver=1.19.0
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
-url='https://code.visualstudio.com/'
+url='https://github.com/Microsoft/vscode'
license=('MIT')
makedepends=('npm' 'nodejs>=6.8.0' 'gulp' 'python2' 'git' 'yarn')
depends=('gtk2' 'gconf' 'libnotify' 'libxss' 'libxtst' 'libxkbfile' 'nss'
'alsa-lib')
-conflicts=('vscode-oss')
-provides=('vscode-oss')
+conflicts=('vscode-oss' 'visual-studio-code-oss')
+provides=('vscode-oss' 'visual-studio-code-oss')
source=("vscode::git+https://github.com/Microsoft/vscode#tag=${pkgver}"
+ "${pkgname}.desktop"
"startup_script.patch"
- "${pkgname}.desktop")
+ "product_json.patch")
sha256sums=('SKIP'
+ 'f472fb49852ae9048966f02278110efbbe451192a8ae312ec05d1c31093a0ff4'
'8b2feded3382e5bf6b5b292c14083bfc536c05cd00f3235dd22b75b67fba134d'
- 'd140d0de9998a2a886a6d2ff23f356f8b68c8aae5a53c33ec87826e5d7ad3529')
-
-if (( VSCODE_NONFREE )); then
- source+=('product_json.patch')
- sha256sums+=('e90f9d69bd42c0d9fc5f081d3bf7ca307df53e3553efadf00d62ced66b1bb070')
- install="${pkgname}.nonfree.install"
- license+=('proprietary')
-fi
+ '7970996eaddbb0265373e71c5452064465472ebb5bd6a393b94e8b84bde24854')
case "$CARCH" in
i686)
@@ -52,13 +42,13 @@ esac
prepare() {
cd "${srcdir}/vscode"
- if (( VSCODE_NONFREE )); then
- patch -p1 -i "${srcdir}/product_json.patch"
- local _commit=$(cd "${srcdir}/vscode" && git rev-parse HEAD)
- local _datestamp=$(date -u -Is | sed 's/\+00:00/Z/')
- sed -e "s/@COMMIT@/${_commit}/" -e "s/@DATE@/${_datestamp}/" \
- -i product.json
- fi
+ # This patch no longer contains proprietary modifications.
+ # See https://github.com/Microsoft/vscode/issues/31168 for details.
+ patch -p1 -i "${srcdir}/product_json.patch"
+ local _commit=$(cd "${srcdir}/vscode" && git rev-parse HEAD)
+ local _datestamp=$(date -u -Is | sed 's/\+00:00/Z/')
+ sed -e "s/@COMMIT@/${_commit}/" -e "s/@DATE@/${_datestamp}/" \
+ -i product.json
}
build() {
@@ -85,9 +75,6 @@ package() {
# Put the startup script in /usr/bin
mv "${pkgdir}/usr/share/code-oss/bin" "${pkgdir}/usr"
- # Add symlink to the name we provided in older versions of this package
- ln -s code-oss "${pkgdir}/usr/bin/${pkgname}"
-
# Add .desktop file
install -D -m644 "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
diff --git a/visual-studio-code-oss.desktop b/code.desktop
index 385b3dd53181..8a15436a0bab 100644
--- a/visual-studio-code-oss.desktop
+++ b/code.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Encoding=UTF-8
Version=1.0
-Name=Visual Studio Code (Open Source)
+Name=Microsoft Code (Open Source)
Comment=Code Editing. Redefined.
GenericName=Text Editor
Exec=/usr/bin/code-oss --unity-launch %F
diff --git a/product_json.patch b/product_json.patch
index a9a4237f1cb6..48ed80be3bd8 100644
--- a/product_json.patch
+++ b/product_json.patch
@@ -1,15 +1,7 @@
diff -rupN a/product.json b/product.json
--- a/product.json 2016-09-08 14:48:45.419566181 -0700
+++ b/product.json 2016-09-08 14:49:43.000000000 -0700
-@@ -1,6 +1,6 @@
- {
- "nameShort": "Code - OSS",
-- "nameLong": "Code - OSS",
-+ "nameLong": "Visual Studio Code - OSS",
- "applicationName": "code-oss",
- "dataFolderName": ".vscode-oss",
- "win32MutexName": "vscodeoss",
-@@ -12,5 +12,19 @@
+@@ -12,5 +12,15 @@
"win32AppUserModelId": "Microsoft.CodeOSS",
"darwinBundleIdentifier": "com.visualstudio.code.oss",
"reportIssueUrl": "https://github.com/Microsoft/vscode/issues/new",
@@ -17,18 +9,14 @@ diff -rupN a/product.json b/product.json
-}
\ No newline at end of file
+ "urlProtocol": "code-oss",
-+ "welcomePage": "http://go.microsoft.com/fwlink/?LinkId=723048",
+ "quality": "stable",
+ "extensionsGallery": {
+ "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
+ "cacheUrl": "https://vscode.blob.core.windows.net/gallery/index",
+ "itemUrl": "https://marketplace.visualstudio.com/items"
+ },
-+ "documentationUrl": "http://go.microsoft.com/fwlink/?LinkID=533484#vscode",
-+ "releaseNotesUrl": "http://go.microsoft.com/fwlink/?LinkID=533483#vscode",
-+ "twitterUrl": "http://go.microsoft.com/fwlink/?LinkID=533687",
-+ "requestFeatureUrl": "http://go.microsoft.com/fwlink/?LinkID=533482",
-+ "privacyStatementUrl": "http://go.microsoft.com/fwlink/?LinkID=528096&clcid=0x409",
++ "documentationUrl": "https://github.com/microsoft/vscode-docs",
++ "requestFeatureUrl": "https://github.com/Microsoft/vscode/issues",
+ "commit": "@COMMIT@",
+ "date": "@DATE@"
+}
diff --git a/visual-studio-code-oss.nonfree.install b/visual-studio-code-oss.nonfree.install
deleted file mode 100644
index 3f51ea6e3373..000000000000
--- a/visual-studio-code-oss.nonfree.install
+++ /dev/null
@@ -1,15 +0,0 @@
-_notice() {
- echo
- echo "NOTICE: This package includes proprietary configuration files which make"
- echo "the package non-free and non-redistributable. If you wish to disable"
- echo "the extra functionality and use the pure open-source package, read the"
- echo "notice at the top of the PKGBUILD and set VSCODE_NONFREE=0"
-}
-
-post_install() {
- _notice
-}
-
-post_upgrade() {
- _notice
-}