summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 550de9c3d26d..aa540e307394 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 17 22:30:02 UTC 2018
+# Tue Apr 10 21:19:18 UTC 2018
pkgbase = code
pkgdesc = Microsoft Code -- The Open Source build of Visual Studio Code (vscode)
- pkgver = 1.21.1
+ pkgver = 1.22.1
pkgrel = 1
url = https://github.com/Microsoft/vscode
arch = i686
@@ -10,7 +10,7 @@ pkgbase = code
arch = armv7h
license = MIT
makedepends = npm
- makedepends = nodejs>=6.8.0
+ makedepends = nodejs>=8.0
makedepends = gulp
makedepends = python2
makedepends = git
@@ -27,7 +27,7 @@ pkgbase = code
provides = visual-studio-code-oss
conflicts = vscode-oss
conflicts = visual-studio-code-oss
- source = vscode::git+https://github.com/Microsoft/vscode#tag=1.21.1
+ source = vscode::git+https://github.com/Microsoft/vscode#tag=1.22.1
source = code.desktop
source = startup_script.patch
source = product_json.patch
diff --git a/.gitignore b/.gitignore
index 022fbdd3bca9..f5931a310475 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/src/
/pkg/
+/vscode/
*.tar.xz
*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0e2471dc72c2..df9dd2c11b83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=code
pkgdesc='Microsoft Code -- The Open Source build of Visual Studio Code (vscode)'
-pkgver=1.21.1
+pkgver=1.22.1
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/Microsoft/vscode'
license=('MIT')
-makedepends=('npm' 'nodejs>=6.8.0' 'gulp' 'python2' 'git' 'yarn')
+makedepends=('npm' 'nodejs>=8.0' 'gulp' 'python2' 'git' 'yarn')
depends=('gtk2' 'gconf' 'libnotify' 'libxss' 'libxtst' 'libxkbfile' 'nss'
'alsa-lib')
conflicts=('vscode-oss' 'visual-studio-code-oss')
@@ -56,11 +56,21 @@ build() {
yarn install --arch=${_vscode_arch}
+ if ! ulimit -n 10000; then
+ echo
+ echo "*** ERROR: Could not raise the soft file limit. ***"
+ echo "You may need to adjust your 'nofile' limit in /etc/security/limits.conf"
+ echo "and possibly also raise your kernel-enforced limit if necessary."
+ echo "Without this change, the gulp build will likely fail with EMFILE"
+ echo
+ exit 1
+ fi
+
# The default memory limit may be too low for current versions of node
# to successfully build vscode. Uncomment this to set it to 2GB, or
# change it if this number still doesn't work for your system.
mem_limit="--max_old_space_size=2048"
- /usr/bin/node $mem_limit /usr/bin/gulp vscode-linux-${_vscode_arch}
+ /usr/bin/node $mem_limit /usr/bin/gulp vscode-linux-${_vscode_arch}-min
# Patch the startup script to know where the app is installed, rather
# than guessing...