summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD48
3 files changed, 35 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa9e97ae0f35..3fa5a7d0ad42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = code-eli-git
pkgdesc = Collection of C++ libraries that provide a variety of functionalities.
- pkgver = 20140913
+ pkgver = r821.f9ff74f
pkgrel = 1
- url = https://github.com/ddmarshall/Code-Eli
+ url = https://github.com/ramcdona/Code-Eli
arch = i686
arch = x86_64
license = EPL 1.0
makedepends = cmake
makedepends = git
+ depends = eigen
+ optdepends = cpptest: unit tests
+ optdepends = doxygen: documentation
provides = code-eli
+ source = git+https://github.com/ramcdona/Code-Eli.git
+ md5sums = SKIP
pkgname = code-eli-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..57621ac85b07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# Exclude all files
+/*
diff --git a/PKGBUILD b/PKGBUILD
index 15646fb2f056..38f1b44801af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,49 @@
# Contributor: Max Devaine <max@devaine.cz>
-
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=code-eli-git
-pkgver=20140913
+pkgver=r821.f9ff74f
pkgrel=1
pkgdesc='Collection of C++ libraries that provide a variety of functionalities.'
-arch=(i686 x86_64)
-url='https://github.com/ddmarshall/Code-Eli'
+arch=('i686' 'x86_64')
+url='https://github.com/ramcdona/Code-Eli'
license=('EPL 1.0')
+depends=('eigen')
+optdepends=('cpptest: unit tests'
+ 'doxygen: documentation')
makedepends=('cmake' 'git')
-depends=('')
+_name=Code-Eli
provides=('code-eli')
conflicts=('')
-groups=('')
+source=("git+https://github.com/ramcdona/Code-Eli.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
-_gitroot="https://github.com/ddmarshall/Code-Eli.git"
-_gitname="Code-Eli"
+_buildtype="Release"
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
- if [ -d "$srcdir/$_gitname" ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
+ msg "Starting CMake (build type: ${_buildtype})"
- msg "GIT checkout done or server timeout"
+ cd "${srcdir}/${_name}/"
- msg "Configure Code-Eli..."
- cd "$srcdir/$_gitname/"
+ cmake . \
+ -DCMAKE_PREFIX_PATH='/usr' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
- cmake . -DCMAKE_PREFIX_PATH='/usr' -DCMAKE_INSTALL_PREFIX='/usr'
-
+ msg "Building the project"
+ make -j4
}
package() {
+ msg "Installing files"
+
mkdir $pkgdir/usr
- cp -a $srcdir/$_gitname/include $pkgdir/usr/
+ cp -a $srcdir/${_name}/include $pkgdir/usr/
chown -R root:root $pkgdir/usr
chmod -R 755 $pkgdir/usr
}