summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4452b4549d22..e24e3a5f72f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = code-eli-git
pkgdesc = Collection of C++ libraries that provide a variety of functionalities.
- pkgver = r821.f9ff74f
- pkgrel = 3
+ pkgver = r826.b6e1bd3
+ pkgrel = 1
url = https://github.com/ramcdona/Code-Eli
arch = i686
arch = x86_64
@@ -13,6 +13,8 @@ pkgbase = code-eli-git
optdepends = doxygen: documentation
provides = code-eli
source = git+https://github.com/ramcdona/Code-Eli.git
+ source = exponent.patch::https://patch-diff.githubusercontent.com/raw/ramcdona/Code-Eli/pull/8.patch
+ md5sums = SKIP
md5sums = SKIP
pkgname = code-eli-git
diff --git a/PKGBUILD b/PKGBUILD
index 7e6a09a8d735..5824ac34ee87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Contributor: Max Devaine <max@devaine.cz>
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Max Devaine <max@devaine.cz>
+
pkgname=code-eli-git
-pkgver=r821.f9ff74f
-pkgrel=3
+pkgver=r826.b6e1bd3
+pkgrel=1
pkgdesc='Collection of C++ libraries that provide a variety of functionalities.'
arch=('i686' 'x86_64')
url='https://github.com/ramcdona/Code-Eli'
@@ -13,15 +14,20 @@ optdepends=('cpptest: unit tests'
makedepends=('cmake' 'git')
_name=Code-Eli
provides=('code-eli')
-source=("git+https://github.com/ramcdona/Code-Eli.git")
-md5sums=('SKIP')
+source=("git+https://github.com/ramcdona/Code-Eli.git"
+ "exponent.patch::https://patch-diff.githubusercontent.com/raw/ramcdona/Code-Eli/pull/8.patch")
+md5sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "$_name"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-_buildtype="Release"
+prepare() {
+ cd "${srcdir}/${_name}"
+ patch --forward --strip=1 --input="${srcdir}/exponent.patch"
+}
build() {
@@ -29,28 +35,20 @@ build() {
mkdir -p "${srcdir}/${_name}/build"
cd "${srcdir}/${_name}/build"
- msg "Starting CMake (build type: ${_buildtype})"
-
cmake .. \
- -DCMAKE_BUILD_TYPE=${_buildtype} \
-DCMAKE_INSTALL_PREFIX='/usr'
- msg "Building the project"
make
-
}
package() {
cd "${srcdir}/${_name}"
- msg "Installing files"
-
mkdir -p "${pkgdir}/usr/include/eli"
# include
cp -r include/eli/* ${pkgdir}/usr/include/eli
cd "${srcdir}/${_name}/build"
cp -r include/eli/* ${pkgdir}/usr/include/eli
-
}