summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--patch.json49
-rwxr-xr-xpatch.py27
-rwxr-xr-xupdate.py2
5 files changed, 59 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6720ac921021..e0889ce56f75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-features-insiders
pkgdesc = Unblock some features in Code OSS, including features in VSCode Insiders
- pkgver = 1.87.0
+ pkgver = 1.89.0
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features-insiders.install
@@ -16,7 +16,7 @@ pkgbase = code-features-insiders
source = patch.py
source = patch.json
md5sums = a270718448070ecda3050b7569510105
- md5sums = f11f7ccd925de0398ef2e28b127bb063
- md5sums = a17f01e570df18126948925f694ce4cd
+ md5sums = 9ed6f3972479ab6d3d053e7c47ead55a
+ md5sums = d9346e05d67382e14de3b56357a3ec98
pkgname = code-features-insiders
diff --git a/PKGBUILD b/PKGBUILD
index 4b8f4979a69d..2b944b4d3c09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features-insiders
-pkgver=1.87.0
+pkgver=1.89.0
pkgrel=1
pkgdesc='Unblock some features in Code OSS, including features in VSCode Insiders'
arch=('any')
@@ -15,8 +15,8 @@ source=("${pkgname}.hook"
'patch.py'
'patch.json')
md5sums=('a270718448070ecda3050b7569510105'
- 'f11f7ccd925de0398ef2e28b127bb063'
- 'a17f01e570df18126948925f694ce4cd')
+ '9ed6f3972479ab6d3d053e7c47ead55a'
+ 'd9346e05d67382e14de3b56357a3ec98')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.json b/patch.json
index d0d3834ddfda..c882aa2f52b3 100644
--- a/patch.json
+++ b/patch.json
@@ -292,15 +292,14 @@
"settingsSearchUrl": "https://bingsettingssearch.trafficmanager.net/api/Search",
"extensionEnabledApiProposals": {
"ms-vscode.vscode-selfhost-test-provider": [
- "testObserver",
- "testCoverage"
- ],
- "ms-vscode.extension-test-runner": [
- "testCoverage"
+ "testObserver"
],
"VisualStudioExptTeam.vscodeintellicode-completions": [
"inlineCompletionsAdditions"
],
+ "ms-toolsai.datawrangler": [
+ "debugFocus"
+ ],
"ms-vsliveshare.vsliveshare": [
"contribMenuBarHome",
"contribShareMenu",
@@ -321,9 +320,6 @@
"workspaceTrust",
"tunnels"
],
- "vscjava.vscode-java-test": [
- "testCoverage"
- ],
"ms-toolsai.vscode-ai-remote": [
"resolvers"
],
@@ -335,7 +331,8 @@
"testObserver",
"quickPickItemTooltip",
"terminalDataWriteEvent",
- "terminalExecuteCommandEvent"
+ "terminalExecuteCommandEvent",
+ "contribIssueReporter"
],
"ms-dotnettools.dotnet-interactive-vscode": [
"notebookMessaging"
@@ -425,20 +422,24 @@
],
"GitHub.vscode-pull-request-github": [
"activeComment",
- "contribCommentThreadAdditionalMenu",
- "tokenInformation",
+ "codiconDecoration",
"codeActionRanges",
+ "commentingRangeHint",
"commentReactor",
- "contribShareMenu",
- "fileComments",
+ "commentThreadApplicability",
+ "contribCommentEditorActionsMenu",
"contribCommentPeekContext",
- "codiconDecoration",
+ "contribCommentThreadAdditionalMenu",
+ "contribCommentsViewThreadMenus",
+ "contribEditorContentMenu",
+ "contribShareMenu",
"diffCommand",
- "contribCommentEditorActionsMenu",
- "treeViewMarkdownMessage",
- "tabInputTextMerge",
+ "fileComments",
+ "quickDiffProvider",
"shareProvider",
- "quickDiffProvider"
+ "tabInputTextMerge",
+ "tokenInformation",
+ "treeViewMarkdownMessage"
],
"GitHub.copilot": [
"inlineCompletionsAdditions",
@@ -470,7 +471,10 @@
"contribSourceControlInputBoxMenu",
"newSymbolNamesProvider",
"findFiles2",
- "extensionsAny"
+ "extensionsAny",
+ "authLearnMore",
+ "testObserver",
+ "aiTextSearchProvider"
],
"GitHub.remotehub": [
"contribRemoteHelp",
@@ -497,7 +501,8 @@
"notebookCellExecutionState"
],
"ms-python.debugpy": [
- "portsAttributes"
+ "portsAttributes",
+ "contribIssueReporter"
],
"ms-toolsai.jupyter-renderers": [
"contribNotebookStaticPreloads"
@@ -515,6 +520,7 @@
"contribNotebookStaticPreloads",
"quickPickItemTooltip",
"notebookExecution",
+ "notebookCellExecution",
"notebookVariableProvider"
],
"dbaeumer.vscode-eslint": [
@@ -847,5 +853,6 @@
]
}
}
- }
+ },
+ "enableTelemetry": false
} \ No newline at end of file
diff --git a/patch.py b/patch.py
index 8e0cb7665ee8..b4710b46f633 100755
--- a/patch.py
+++ b/patch.py
@@ -11,10 +11,27 @@ product_path = "/usr/lib/code/product.json"
patch_path = "/usr/share/%s/patch.json" % pkt_name
cache_path = "/usr/share/%s/cache.json" % pkt_name
+
+class term_colors:
+ WARNING = "\033[93m"
+ ENDC = "\033[0m"
+
+
+if not os.path.exists(product_path):
+ print(
+ term_colors.WARNING
+ + "WARN: "
+ + term_colors.ENDC
+ + product_path
+ + " does not exist. You need to install extra/code in the official repository to use this package. Skipping..."
+ )
+ exit(0)
+
if not os.path.exists(cache_path):
- with open(cache_path, 'w') as file:
+ with open(cache_path, "w") as file:
file.write("{}")
+
def patch():
with open(product_path, "r") as product_file:
product_data = json.load(product_file)
@@ -26,9 +43,10 @@ def patch():
cache_data[key] = product_data[key]
product_data[key] = patch_data[key]
with open(product_path, "w") as product_file:
- json.dump(product_data, product_file, indent='\t')
+ json.dump(product_data, product_file, indent="\t")
with open(cache_path, "w") as cache_file:
- json.dump(cache_data, cache_file, indent='\t')
+ json.dump(cache_data, cache_file, indent="\t")
+
def restore():
with open(product_path, "r") as product_file:
@@ -43,7 +61,8 @@ def restore():
for key in cache_data.keys():
product_data[key] = cache_data[key]
with open(product_path, "w") as product_file:
- json.dump(product_data, product_file, indent='\t')
+ json.dump(product_data, product_file, indent="\t")
+
if operation == "patch":
patch()
diff --git a/update.py b/update.py
index ff54586d9a35..3db26ed6bb33 100755
--- a/update.py
+++ b/update.py
@@ -48,5 +48,7 @@ patch_data = {}
for key in key_list:
patch_data[key] = product_data[key]
+patch_data["enableTelemetry"] = False
+
with open(patch_path, "w") as patch_file:
json.dump(patch_data, patch_file, indent='\t')