summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c975b5605eee..f4518481e851 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-headmelted-bin
pkgdesc = Community builds of Visual Studio Code, including for ARM devices
- pkgver = 1.42.0
+ pkgver = 1.42.0_2020_01_13
pkgrel = 1
url = https://code.headmelted.com
arch = armv7h
@@ -19,10 +19,10 @@ pkgbase = code-headmelted-bin
conflicts = code
conflicts = vscode-headmelted-bin
replaces = vscode-headmelted-bin
- source_armv7h = https://github.com/headmelted/codebuilds/releases/download/10-Dec-19/code-oss_1.42.0-1575959634_armhf.deb
- md5sums_armv7h = f984c8cfd2f7826b5793da14436c54ef
- source_aarch64 = https://github.com/headmelted/codebuilds/releases/download/10-Dec-19/code-oss_1.42.0-1575959662_arm64.deb
- md5sums_aarch64 = b2f20657be5db0280e15db05ad9cabe0
+ source_armv7h = https://github.com/headmelted/codebuilds/releases/download/13-Jan-20/code-oss_1.42.0-1578878180_armhf.deb
+ md5sums_armv7h = 10650409f5c7095a7304ca0624301674
+ source_aarch64 = https://github.com/headmelted/codebuilds/releases/download/13-Jan-20/code-oss_1.42.0-1578878212_arm64.deb
+ md5sums_aarch64 = de7e11e7fa0d4ab08d72bc758b399bc0
pkgname = code-headmelted-bin
diff --git a/PKGBUILD b/PKGBUILD
index 06ab45410556..05bf4542cd30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,11 @@
# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk>
pkgname=code-headmelted-bin
-pkgver=1.42.0
+_pkgver=1.42.0
+_date=2020_01_13
+_url=https://github.com/headmelted/codebuilds/releases/download/13-Jan-20
+_armhf_build=1578878180
+_arm64_build=1578878212
+pkgver="${_pkgver}_${_date}"
pkgrel=1
pkgdesc="Community builds of Visual Studio Code, including for ARM devices"
arch=(armv7h aarch64)
@@ -11,11 +16,10 @@ optdepends=("trash-cli: For moving items to trash")
provides=(code vscode-headmelted-bin)
replaces=(vscode-headmelted-bin)
conflicts=(code vscode-headmelted-bin)
-_url=https://github.com/headmelted/codebuilds/releases/download/10-Dec-19
-source_armv7h=("$_url/code-oss_$pkgver-1575959634_armhf.deb")
-source_aarch64=("$_url/code-oss_$pkgver-1575959662_arm64.deb")
-md5sums_armv7h=('f984c8cfd2f7826b5793da14436c54ef')
-md5sums_aarch64=('b2f20657be5db0280e15db05ad9cabe0')
+source_armv7h=("$_url/code-oss_$_pkgver-${_armhf_build}_armhf.deb")
+source_aarch64=("$_url/code-oss_$_pkgver-${_arm64_build}_arm64.deb")
+md5sums_armv7h=('10650409f5c7095a7304ca0624301674')
+md5sums_aarch64=('de7e11e7fa0d4ab08d72bc758b399bc0')
package() {
msg2 "Extracting the data.tar.xz..."