summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xcode-oss.sh18
3 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54e84f0aea28..320a0aff787c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = code-translucent
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor with translucent window, official marketplace, unblocked proprietary features and wayland support!
- pkgver = 1.83.0
- pkgrel = 2
+ pkgver = 1.83.1
+ pkgrel = 1
url = https://github.com/microsoft/vscode
arch = x86_64
arch = i686
@@ -28,13 +28,13 @@ pkgbase = code-translucent
optdepends = icu69: Needed for live share
provides = code-oss
conflicts = code-oss
- source = code-translucent::git+https://github.com/microsoft/vscode.git#tag=1.83.0
+ source = code-translucent::git+https://github.com/microsoft/vscode.git#tag=1.83.1
source = build-with-chroot.sh
source = translucent.patch
source = code-oss.sh
sha512sums = SKIP
sha512sums = 9de3f195e711814e1e457e8ccb6383c6000bc83ee707f2bc138fe66c3cf6c35a6e9c755594afb5fbf8c4f05c3c87f7f3b8714e7947b62094ead6f5f1b81f5b24
sha512sums = ed6f305629d5858579b44d3d037b9ac85fe1ca84cab583b19324da765b5b39ca7f31a0e69d857185030c07f89bdd5e450969515f104b09a3f0ce76c19839a021
- sha512sums = d1620dc3995c83639baea60ce58becf2b8c7501e1bcb81d4a96e60bf9e26489f99ba7ead9306ad703145bd3ce12c00ecdc20568d25c0b67dac716031ce3ccf35
+ sha512sums = 443d946fd1b01ac234c80c2f3a90fd1bf6f8a094f3fcaa792ffb5730e92319646c3edb54fd3183f3c9238dfef4474b2d6d59edd8166220d76024e2d2dbe3fe5a
pkgname = code-translucent
diff --git a/PKGBUILD b/PKGBUILD
index e7779fafee57..c5988638bfa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: David Čuček <observ33r@gmail.com>
pkgname="code-translucent"
-pkgver=1.83.0
-pkgrel=2
+pkgver=1.83.1
+pkgrel=1
pkgdesc="The Open Source build of Visual Studio Code (vscode) editor with translucent window, official marketplace, unblocked proprietary features and wayland support!"
arch=(
@@ -56,7 +56,7 @@ sha512sums=(
"SKIP"
"9de3f195e711814e1e457e8ccb6383c6000bc83ee707f2bc138fe66c3cf6c35a6e9c755594afb5fbf8c4f05c3c87f7f3b8714e7947b62094ead6f5f1b81f5b24"
"ed6f305629d5858579b44d3d037b9ac85fe1ca84cab583b19324da765b5b39ca7f31a0e69d857185030c07f89bdd5e450969515f104b09a3f0ce76c19839a021"
- "d1620dc3995c83639baea60ce58becf2b8c7501e1bcb81d4a96e60bf9e26489f99ba7ead9306ad703145bd3ce12c00ecdc20568d25c0b67dac716031ce3ccf35"
+ "443d946fd1b01ac234c80c2f3a90fd1bf6f8a094f3fcaa792ffb5730e92319646c3edb54fd3183f3c9238dfef4474b2d6d59edd8166220d76024e2d2dbe3fe5a"
)
case "${CARCH}" in
diff --git a/code-oss.sh b/code-oss.sh
index 483ea84d7b4d..0412ba4ee5ce 100755
--- a/code-oss.sh
+++ b/code-oss.sh
@@ -20,6 +20,18 @@ in_array() {
}
+is_wayland() {
+
+ [[ "${XDG_SESSION_TYPE}" == "wayland" ]] \
+ && return 0
+
+ [[ -n "${WAYLAND_DISPLAY}" ]] \
+ && return 0
+
+ return 1
+
+}
+
main() {
local -a CODE_USER_FLAGS=()
@@ -30,9 +42,7 @@ main() {
[[ -f "${CODE_CONF_PATH}" ]] \
&& { mapfile -t CODE_USER_FLAGS <<< "$(sed 's/#.*//' ${CODE_CONF_PATH})"; }
- [[ "${XDG_SESSION_TYPE}" == "wayland" ]] && {
-
- unset DISPLAY
+ is_wayland && {
in_array CODE_USER_FLAGS '^--ozone-platform=wayland$' \
|| CODE_USER_FLAGS+=('--ozone-platform=wayland')
@@ -42,7 +52,7 @@ main() {
}
- exec "${CODE_BIN_PATH}" "${CODE_USER_FLAGS[@]}" "$@"
+ exec "${CODE_BIN_PATH}" "$@" "${CODE_USER_FLAGS[@]}"
exit 0