summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--product_json.diff10
-rw-r--r--transparent.diff11
4 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 984170ffa30e..203c063a682f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-transparent
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - with transparency enabled.
- pkgver = 1.49.0
+ pkgver = 1.50.1
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-transparent.install
@@ -11,8 +11,8 @@ pkgbase = code-transparent
makedepends = npm
makedepends = python2
makedepends = yarn
- makedepends = nodejs-lts-dubnium
- depends = electron
+ makedepends = nodejs-lts-erbium
+ depends = electron9
depends = libsecret
depends = libx11
depends = libxkbfile
@@ -22,7 +22,7 @@ pkgbase = code-transparent
optdepends = x11-ssh-askpass: SSH authentication
provides = code
conflicts = code
- source = code::git+https://github.com/microsoft/vscode.git#tag=1.49.0
+ source = code::git+https://github.com/microsoft/vscode.git#tag=1.50.1
source = code.js
source = code.sh
source = product_json.diff
@@ -30,8 +30,8 @@ pkgbase = code-transparent
sha512sums = SKIP
sha512sums = 814c9554427183cd893a33cd2cbe91f6e0ea71921ef0717c86217b1d3058d265f9ff7a9ace3e7b76f122e60b7686475cf4d999e581a1845face3033afb9f745f
sha512sums = 0e75ee88274cbaf48c59ef6f363f6b8ac2ea83f8b17a61155008db773b709a1f0233754fa63a136ec0417313ba90a7eb17db000ec22a38ca8840d8ba6c47cab1
- sha512sums = 8ec47e497287d67f37e7b669af416f43d5cdbd4574892867d7b95996ef5de53640b5bc919b06b177e1fd91cb005579d6ed0c17325117b9914ba7cf28f5f06e40
- sha512sums = 680804ebe32b653df274a71b68f10a72eb478141095e8d360dcb45ad8139f2f3a31d4eeac6ddc9a5a9e615b79a3584e1fa5cdb98ff32884313337aa27da3b957
+ sha512sums = b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7
+ sha512sums = ae7fc5d2d1851bf9353c3f531a4de05cc5b41496468e908776b7a17cf85e889c601b94499bd6165efb902578af1ebf37443a03881f98d8c6120cb4f8667d8fe7
pkgname = code-transparent
diff --git a/PKGBUILD b/PKGBUILD
index 288d22f0bf5f..a187c45590d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - with tran
# - ?: 11 (not in repos)
# - erbium: 12
# Important: Remember to check https://github.com/microsoft/vscode/blob/master/.yarnrc (choose correct tag) for target electron version
-_electron=electron
-pkgver=1.49.0
+_electron=electron9
+pkgver=1.50.1
pkgrel=1
arch=('x86_64')
url='https://github.com/microsoft/vscode'
@@ -23,7 +23,7 @@ depends=($_electron 'libsecret' 'libx11' 'libxkbfile' 'ripgrep')
optdepends=('bash-completion: Bash completions'
'zsh-completions: ZSH completitons'
'x11-ssh-askpass: SSH authentication')
-makedepends=('git' 'gulp' 'npm' 'python2' 'yarn' 'nodejs-lts-dubnium')
+makedepends=('git' 'gulp' 'npm' 'python2' 'yarn' 'nodejs-lts-erbium')
conflicts=('code')
provides=('code')
install='code-transparent.install'
@@ -35,8 +35,8 @@ source=("$_pkgname::git+$url.git#tag=$pkgver"
sha512sums=('SKIP'
'814c9554427183cd893a33cd2cbe91f6e0ea71921ef0717c86217b1d3058d265f9ff7a9ace3e7b76f122e60b7686475cf4d999e581a1845face3033afb9f745f'
'0e75ee88274cbaf48c59ef6f363f6b8ac2ea83f8b17a61155008db773b709a1f0233754fa63a136ec0417313ba90a7eb17db000ec22a38ca8840d8ba6c47cab1'
- '8ec47e497287d67f37e7b669af416f43d5cdbd4574892867d7b95996ef5de53640b5bc919b06b177e1fd91cb005579d6ed0c17325117b9914ba7cf28f5f06e40'
- '680804ebe32b653df274a71b68f10a72eb478141095e8d360dcb45ad8139f2f3a31d4eeac6ddc9a5a9e615b79a3584e1fa5cdb98ff32884313337aa27da3b957')
+ 'b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7'
+ 'ae7fc5d2d1851bf9353c3f531a4de05cc5b41496468e908776b7a17cf85e889c601b94499bd6165efb902578af1ebf37443a03881f98d8c6120cb4f8667d8fe7')
# Even though we don't officially support other archs, let's
# allow the user to use this PKGBUILD to compile the package
@@ -149,7 +149,7 @@ package() {
install -Dm 644 $_pkgname/resources/linux/code.appdata.xml "$pkgdir"/usr/share/metainfo/code-oss.appdata.xml
install -Dm 644 $_pkgname/resources/linux/code.desktop "$pkgdir"/usr/share/applications/code-oss.desktop
install -Dm 644 $_pkgname/resources/linux/code-url-handler.desktop "$pkgdir"/usr/share/applications/code-oss-url-handler.desktop
- install -Dm 644 VSCode-linux-$_vscode_arch/resources/app/resources/linux/code.png "$pkgdir"/usr/share/pixmaps/code-oss.png
+ install -Dm 644 VSCode-linux-$_vscode_arch/resources/app/resources/linux/code.png "$pkgdir"/usr/share/pixmaps/com.visualstudio.code.oss.png
# Install bash and zsh completions
install -Dm 644 $_pkgname/resources/completions/bash/code "$pkgdir"/usr/share/bash-completion/completions/code
diff --git a/product_json.diff b/product_json.diff
index 173b26efb61d..00ddbae005e1 100644
--- a/product_json.diff
+++ b/product_json.diff
@@ -1,13 +1,15 @@
--- product.json 2019-04-06 13:26:49.879655883 +0100
+++ product.json 2019-04-06 13:26:37.399656243 +0100
-@@ -1,4 +1,17 @@
+@@ -1,4 +1,19 @@
{
+ "quality": "stable",
+ "extensionsGallery": {
-+ "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
-+ "cacheUrl": "https://vscode.blob.core.windows.net/gallery/index",
-+ "itemUrl": "https://marketplace.visualstudio.com/items"
++ "serviceUrl": "https://open-vsx.org/vscode/gallery",
++ "itemUrl": "https://open-vsx.org/vscode/item"
+ },
++ "linkProtectionTrustedDomains": [
++ "https://open-vsx.org"
++ ],
+ "documentationUrl": "https://code.visualstudio.com/docs",
+ "requestFeatureUrl": "https://github.com/Microsoft/vscode/issues",
+ "introductoryVideosUrl": "https://go.microsoft.com/fwlink/?linkid=832146",
diff --git a/transparent.diff b/transparent.diff
index ce963311e6c2..be07c42fb336 100644
--- a/transparent.diff
+++ b/transparent.diff
@@ -1,5 +1,4 @@
diff --git a/src/main.js b/src/main.js
-index d5f4c90..5e4dba7 100644
--- a/src/main.js
+++ b/src/main.js
@@ -157,6 +157,9 @@ function configureCommandlineSwitchesSync(cliArgs) {
@@ -13,19 +12,18 @@ index d5f4c90..5e4dba7 100644
const jsFlags = getJSFlags(cliArgs);
if (jsFlags) {
diff --git a/src/vs/code/electron-main/window.ts b/src/vs/code/electron-main/window.ts
-index b55f409..8c61319 100644
--- a/src/vs/code/electron-main/window.ts
+++ b/src/vs/code/electron-main/window.ts
-@@ -122,7 +122,8 @@ export class CodeWindow extends Disposable implements ICodeWindow {
+@@ -157,7 +157,8 @@ width: this.windowState.width,
height: this.windowState.height,
x: this.windowState.x,
y: this.windowState.y,
- backgroundColor: this.themeMainService.getBackgroundColor(),
+ transparent: true,
+ backgroundColor: '#00000000' || this.themeMainService.getBackgroundColor(),
- minWidth: CodeWindow.MIN_WIDTH,
- minHeight: CodeWindow.MIN_HEIGHT,
- show: !isFullscreenOrMaximized,
+ minWidth: WindowMinimumSize.WIDTH,
+ minHeight: WindowMinimumSize.HEIGHT,
+ show: !isFullscreenOrMaximized,
diff --git a/src/vs/workbench/common/theme.ts b/src/vs/workbench/common/theme.ts
--- a/src/vs/workbench/common/theme.ts 2020-04-21 11:28:02.140938188 +0800
+++ b/src/vs/workbench/common/theme.ts 2020-04-21 11:36:36.133491755 +0800
@@ -66,7 +64,6 @@ diff --git a/src/vs/workbench/common/theme.ts b/src/vs/workbench/common/theme.ts
// < --- Tabs --- >
diff --git a/src/vs/workbench/contrib/terminal/browser/terminalInstance.ts b/src/vs/workbench/contrib/terminal/browser/terminalInstance.ts
-index 373f411..16d74ca 100644
--- a/src/vs/workbench/contrib/terminal/browser/terminalInstance.ts
+++ b/src/vs/workbench/contrib/terminal/browser/terminalInstance.ts
@@ -466,6 +466,7 @@ export class TerminalInstance extends Disposable implements ITerminalInstance {