summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD40
-rw-r--r--codegrade-fs-electron.install9
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..882395d2e403
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = codegrade-fs-electron
+ pkgdesc = Electron frontend for the CodeGrade filesystem
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://codegrade.com
+ install = codegrade-fs-electron.install
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ makedepends = npm
+ makedepends = python
+ depends = python-codegrade-fs
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
+ depends = libappindicator-gtk2
+ depends = libappindicator-gtk3
+ source = codegrade-fs-electron-1.1.2::git+https://github.com/CodeGra-de/CodeGra.fs.git#commit=50d99b53fe6043382ed514377394f73d6335191f
+ sha256sums = SKIP
+
+pkgname = codegrade-fs-electron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94fe1c9cd863
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Lorian Coltof <loriancoltof@gmail.com>
+
+pkgname=codegrade-fs-electron
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Electron frontend for the CodeGrade filesystem"
+arch=('x86_64')
+license=('AGPL3')
+
+url="https://codegrade.com"
+depends=('python-codegrade-fs' 'c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk2' 'libappindicator-gtk3')
+makedepends=('git' 'npm' 'python')
+source=("$pkgname-$pkgver::git+https://github.com/CodeGra-de/CodeGra.fs.git#commit=50d99b53fe6043382ed514377394f73d6335191f")
+sha256sums=('SKIP')
+install=codegrade-fs-electron.install
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Output Pacman archive instead of .deb
+ sed -i '96s/deb/pacman/' package.json
+
+ npm install
+}
+
+build() {
+ cd $pkgname-$pkgver
+
+ npm run build:linux:x64
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ tar -C "${pkgdir}/" -xf dist/codegrade-fs-${pkgver}.pacman
+ rm "${pkgdir}/.PKGINFO" "${pkgdir}/.INSTALL" "${pkgdir}/.MTREE"
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/codegrade-fs-electron.install b/codegrade-fs-electron.install
new file mode 100644
index 000000000000..388ee698e890
--- /dev/null
+++ b/codegrade-fs-electron.install
@@ -0,0 +1,9 @@
+post_install() {
+ # Link to the binary
+ ln -sf '/opt/CodeGrade Filesystem/codegrade-fs' '/usr/local/bin/codegrade-fs'
+}
+
+post_remove() {
+ # Delete the link to the binary
+ rm -f '/usr/local/bin/codegrade-fs'
+}