summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71f92ec39f74..9ebc7309ab6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 5 14:00:10 UTC 2016
+# Fri Jul 29 16:45:03 UTC 2016
pkgbase = codelite
pkgdesc = Open-source, cross platform IDE for the C/C++ programming languages
- pkgver = 9.1
+ pkgver = 9.2
pkgrel = 1
url = http://www.codelite.org/
arch = i686
@@ -20,12 +20,13 @@ pkgbase = codelite
depends = ncurses
depends = valgrind
depends = libmariadbclient
+ depends = clang
depends = lldb
optdepends = graphviz: callgraph visualization
noextract = wxgui.zip
- source = https://github.com/eranif/codelite/archive/9.1.tar.gz
+ source = https://github.com/eranif/codelite/archive/9.2.tar.gz
source = http://repos.codelite.org/wxCrafterLibs/wxgui.zip
- md5sums = e1ae35b6e6b63e774a75fe7d02892055
+ md5sums = 77f24e8c39160222ec23f7794a1fc64b
md5sums = 093485fcae62073ca8d0ba6ff3a5cb69
pkgname = codelite
diff --git a/PKGBUILD b/PKGBUILD
index ddb8ab57918a..1e27bb5eeb98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,20 +11,20 @@
#
pkgname=codelite
-pkgver=9.1
+pkgver=9.2
pkgrel=1
pkgdesc="Open-source, cross platform IDE for the C/C++ programming languages"
arch=('i686' 'x86_64')
url="http://www.codelite.org/"
license=('GPL')
-depends=('wxgtk' 'curl' 'webkitgtk2' 'libssh' 'xterm' 'python2' 'libedit' 'ncurses' 'valgrind' 'libmariadbclient' 'lldb')
+depends=('wxgtk' 'curl' 'webkitgtk2' 'libssh' 'xterm' 'python2' 'libedit' 'ncurses' 'valgrind' 'libmariadbclient' 'clang' 'lldb')
makedepends=('pkgconfig' 'cmake')
optdepends=('graphviz: callgraph visualization')
source=(https://github.com/eranif/${pkgname}/archive/${pkgver//_/-}.tar.gz
http://repos.codelite.org/wxCrafterLibs/wxgui.zip)
-md5sums=('e1ae35b6e6b63e774a75fe7d02892055'
+md5sums=('77f24e8c39160222ec23f7794a1fc64b'
'093485fcae62073ca8d0ba6ff3a5cb69')
#if [[ "$CARCH" == 'i686' ]]; then
@@ -50,9 +50,9 @@ build() {
mkdir -p build
cd build
- # ArchLinux: CL 9.1.0 still needs to be built without LLDB because of error: Option 'aarch64-reserve-x18' registered more than once
- #cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DENABLE_CLANG=1 -DENABLE_LLDB=1 -DWITH_MYSQL=1 -DCMAKE_INSTALL_LIBDIR=lib ..
- cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DENABLE_CLANG=1 -DENABLE_LLDB=0 -DWITH_MYSQL=1 -DCMAKE_INSTALL_LIBDIR=lib ..
+ # ArchLinux: CL 9.1.0 needs to be built without LLDB (clang-3.7) because of error: Option 'aarch64-reserve-x18' registered more than once
+ #cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DENABLE_CLANG=1 -DENABLE_LLDB=0 -DWITH_MYSQL=1 -DCMAKE_INSTALL_LIBDIR=lib ..
+ cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DENABLE_CLANG=1 -DENABLE_LLDB=1 -DWITH_MYSQL=1 -DCMAKE_INSTALL_LIBDIR=lib ..
make
}