summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..086a3b038f0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = codicefiscale
+ pkgdesc = The tax code in Italy is an alphanumeric code with a fixed length of 16 characters, inspired by the use of library, which is used to uniquely identify the tax and administrative citizens.
+ pkgver = 2.2.1
+ pkgrel = 2
+ url = http://www.codelinsoft.it/sito/2013-11-17-17-56-34/codice-fiscale.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = qt4
+ source = http://www.codelinsoft.it/sito/download/categoria-linux/CodiceFiscale/codice-fiscale-source.raw
+ md5sums = 5f1ddab88c84b972f9bca075cdaf6ebf
+
+pkgname = codicefiscale
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..85c505f03618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Calogero e Angelo ScarnĂ  <info@codelinsoft.it>
+pkgname=codicefiscale
+pkgver=2.2.1
+pkgrel=2
+pkgdesc="The tax code in Italy is an alphanumeric code with a fixed length of 16 characters, inspired by the use of library, which is used to uniquely identify the tax and administrative citizens."
+url="http://www.codelinsoft.it/sito/2013-11-17-17-56-34/codice-fiscale.html"
+arch=('i686' 'x86_64')
+depends=('qt4')
+license=(LGPL)
+source=(http://www.codelinsoft.it/sito/download/categoria-linux/CodiceFiscale/codice-fiscale-source.raw)
+md5sums=("5f1ddab88c84b972f9bca075cdaf6ebf")
+
+
+
+build() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+qmake-qt4
+make -j5
+}
+
+package() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+install -d "$pkgdir"/opt
+install -dm 755 ${pkgdir}/opt/codicefiscale
+cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/codicefiscale" "${pkgdir}/opt/codicefiscale/"
+cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/update" "${pkgdir}/opt/codicefiscale/"
+cp -rv "${srcdir}/${pkgname}-${pkgver}/cod_fisc/images/codicefisc.png" "${pkgdir}/opt/codicefiscale/"
+install -Dm644 "${srcdir}/${pkgname}-${pkgver}/cod_fisc/desktop/codicefiscale.desktop" "${pkgdir}/usr/share/applications/codicefiscale.desktop"
+
+
+}
+