summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da19d306ee96..9600e84877ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 22 12:43:04 UTC 2015
+# Sat Feb 13 09:47:15 UTC 2016
pkgbase = coedit-bin
pkgdesc = Coedit is an IDE for the DMD D2 compiler.
- pkgver = 2_alpha_4
+ pkgver = 2_gold
pkgrel = 1
url = https://github.com/BBasile/Coedit
arch = x86
@@ -11,8 +11,8 @@ pkgbase = coedit-bin
makedepends = unzip
optdepends = dlang
provides = coedit
- source = https://github.com/BBasile/Coedit/releases/download/2_alpha_4/coedit.2alpha4.linux32.zip
- md5sums = 04546ed1ae38d1ee981d5071a8278a96
+ source = https://github.com/BBasile/Coedit/releases/download/2_gold/coedit.2gold.linux32.zip
+ md5sums = 733c4dc64e7106674d5ab712892b9866
pkgname = coedit-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4f684a921aa6..94aac95dc5de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Marius O<marius@habarnam.ro>
pkgname=coedit-bin
-pkgver=2_alpha_4
+pkgver=2_gold
pkgrel=1
pkgdesc="Coedit is an IDE for the DMD D2 compiler."
url="https://github.com/BBasile/Coedit"
@@ -15,17 +15,20 @@ else
_arch="32"
fi
source=("https://github.com/BBasile/Coedit/releases/download/${pkgver}/${pkgname%-bin}.${pkgver//_}.linux${_arch}.zip")
-md5sums=('04546ed1ae38d1ee981d5071a8278a96')
+md5sums=('733c4dc64e7106674d5ab712892b9866')
package() {
- cd "${srcdir}"
mkdir -p "${pkgdir}/usr/bin"
mkdir -p "${pkgdir}/usr/share/icons"
mkdir -p "${pkgdir}/usr/share/applications"
+
+ _dir="${pkgname%-bin}-${CARCH}"
+ cd "${srcdir}/${_dir}"
+
cp coedit "${pkgdir}/usr/bin"
cp cesyms "${pkgdir}/usr/bin"
cp cetodo "${pkgdir}/usr/bin"
cp coedit.png "${pkgdir}/usr/share/icons"
- cp ../coedit.desktop "${pkgdir}/usr/share/applications"
+ cp ../../coedit.desktop "${pkgdir}/usr/share/applications"
}