summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7766bcc6f68..1fffbbd03fc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = coffee-git
pkgdesc = Keep up with current news and weather with Coffee
- pkgver = 1.1.0.r0.g5b43105
+ pkgver = 1.1.0.r13.gf765072
pkgrel = 1
url = https://nick92.github.io/coffee/
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = meson
makedepends = vala
- depends = geocode-glib
+ depends = geoclue
depends = libgee
depends = webkit2gtk
provides = coffee
conflicts = coffee
- source = git+https://github.com/nick92/coffee.git
+ source = coffee::git+https://github.com/nick92/coffee.git
sha256sums = SKIP
pkgname = coffee-git
diff --git a/PKGBUILD b/PKGBUILD
index df84ecdbce74..d7646b74ad9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,29 @@
# Contributor:
pkgname=coffee-git
-pkgver=1.1.0.r0.g5b43105
+pkgver=1.1.0.r13.gf765072
pkgrel=1
pkgdesc="Keep up with current news and weather with Coffee"
-arch=('i686' 'x86_64')
-url="https://nick92.github.io/coffee/"
+arch=('x86_64')
+url='https://nick92.github.io/coffee/'
license=('GPL3')
-depends=('geocode-glib' 'libgee' 'webkit2gtk')
+depends=('geoclue' 'libgee' 'webkit2gtk')
makedepends=('git' 'meson' 'vala')
provides=('coffee')
conflicts=('coffee')
-source=('git+https://github.com/nick92/coffee.git')
+source=('coffee::git+https://github.com/nick92/coffee.git')
sha256sums=('SKIP')
pkgver() {
- cd coffee
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd coffee
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd coffee
- rm -rf _build
- meson _build --prefix=/usr
- ninja -C _build
+ arch-meson coffee build
+ ninja -C build
}
package() {
- cd coffee
- env DESTDIR="$pkgdir" ninja -C _build install
+ DESTDIR="$pkgdir" ninja -C build install
}