summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--nvm-export.patch2
-rw-r--r--sse_sum.patch18
4 files changed, 5 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60c32af8293b..1eb74a70fb72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = colmap-git
pkgdesc = COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface.
- pkgver = 3.5.dev.2.r9.gf4e2a25
+ pkgver = 3.5.dev.2.r16.g983b558
pkgrel = 1
url = https://colmap.github.io/
install = colmap-git.install
@@ -25,14 +25,12 @@ pkgbase = colmap-git
optdepends = cuda-toolkit: for cuda sfm/mvs acceleration
source = colmap-git::git+https://github.com/colmap/colmap.git#branch=dev
source = nvm-export.patch
- source = sse_sum.patch
source = colmap-git.install
source = vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin
source = vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin
source = vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin
md5sums = SKIP
- md5sums = 3c0027625739e972f8af8bea6f557b35
- md5sums = 0102c94336f466f9d5a9716fe2310821
+ md5sums = 1542bbbaa7951dbf0b2472354b4b493d
md5sums = ebb1dc43e014a1e720a06422c6248a40
md5sums = 3521ff3c601596473c6ce5256772f606
md5sums = e423daecc45d56b749d25eeace9de1c8
diff --git a/PKGBUILD b/PKGBUILD
index acb91fef714e..05c116109c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ name=colmap
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
fragment="#branch=dev"
pkgname=${name}-git
-pkgver=3.5.dev.2.r9.gf4e2a25
+pkgver=3.5.dev.2.r16.g983b558
pkgrel=1
pkgdesc="COLMAP is a general-purpose Structure-from-Motion (SfM) and Multi-View Stereo (MVS) pipeline with a graphical and command-line interface."
arch=('i686' 'x86_64')
@@ -22,15 +22,13 @@ fi
install=${pkgname}.install
source=("${pkgname}::git+https://github.com/colmap/colmap.git${fragment}"
"nvm-export.patch"
- "sse_sum.patch"
"${pkgname}.install"
"vocabulary-tree-64K.bin::https://demuc.de/colmap/vocab_tree-65536.bin"
"vocabulary-tree-256K.bin::https://demuc.de/colmap/vocab_tree-262144.bin"
"vocabulary-tree-1M.bin::https://demuc.de/colmap/vocab_tree-1048576.bin"
)
md5sums=('SKIP'
- '3c0027625739e972f8af8bea6f557b35'
- '0102c94336f466f9d5a9716fe2310821'
+ '1542bbbaa7951dbf0b2472354b4b493d'
'ebb1dc43e014a1e720a06422c6248a40'
'3521ff3c601596473c6ce5256772f606'
'e423daecc45d56b749d25eeace9de1c8'
@@ -44,7 +42,6 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
git apply ${srcdir}/nvm-export.patch
- git apply ${srcdir}/sse_sum.patch
}
diff --git a/nvm-export.patch b/nvm-export.patch
index 0ef590c27c2e..d1442038e1f2 100644
--- a/nvm-export.patch
+++ b/nvm-export.patch
@@ -19,7 +19,7 @@ index c9a65fc..29358b3 100755
+ //fix white space in nvm path acordingly
+ std::string image_path_nvm = image_path ;
+ std::transform(image_path_nvm.begin(), image_path_nvm.end(), image_path_nvm.begin(), [](char ch) {
-+ return ch == ' ' ? '"' : ch;
++ return ch == ' ' ? '"' : ch;
+ });
+
+ file << JoinPaths(image_path_nvm, image.Name()) << " ";
diff --git a/sse_sum.patch b/sse_sum.patch
deleted file mode 100644
index 77df49472412..000000000000
--- a/sse_sum.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/lib/PBA/SparseBundleCPU.cpp b/lib/PBA/SparseBundleCPU.cpp
-index 2967cc7..b037082 100755
---- a/lib/PBA/SparseBundleCPU.cpp
-+++ b/lib/PBA/SparseBundleCPU.cpp
-@@ -354,11 +354,11 @@ inline double sse_sum(__m256d s) {
- return (s.m256d_f64[0] + s.m256d_f64[2]) + (s.m256d_f64[1] + s.m256d_f64[3]);
- }
- #else
--inline float sse_sum(__m128 s) {
-+inline float sse_sum(__m256 s) {
- float* f = (float*)(&s);
- return ((f[0] + f[4]) + (f[2] + f[6])) + ((f[1] + f[5]) + (f[3] + f[7]));
- }
--inline double sse_sum(__m128d s) {
-+inline double sse_sum(__m256d s) {
- double* d = (double*)(&s);
- return (d[0] + d[2]) + (d[1] + d[3]);
- }