summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
-rw-r--r--command-not-found.install1
3 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9d43b74445d..ac507ce249fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jan 1 22:50:04 UTC 2017
pkgbase = command-not-found
pkgdesc = In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh).
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = http://github.com/metti/command-not-found
install = command-not-found.install
@@ -8,15 +10,14 @@ pkgbase = command-not-found
arch = x86_64
license = GPL
makedepends = boost
- makedepends = tdb
makedepends = cmake
makedepends = git
depends = boost-libs
- depends = tdb
depends = libarchive
+ depends = tdb
depends = wget
- source = https://github.com/metti/command-not-found/archive/v0.5.0.zip
- md5sums = 3f7f705dc151b33742e888bcef17b58b
+ source = http://github.com/metti/command-not-found/archive/v0.6.0.zip
+ md5sums = e991b83a0f0a65b4180683cd04c845e5
pkgname = command-not-found
diff --git a/PKGBUILD b/PKGBUILD
index ac038af18387..d5587816429d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Justin Dray <justin@dray.be>
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
# Contributor: Matthias Maennich <arch@maennich.net>
+
pkgname=command-not-found
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh)."
arch=('i686' 'x86_64')
-url="http://github.com/metti/command-not-found"
+url="http://github.com/metti/$pkgname"
license=('GPL')
-depends=('boost-libs' 'tdb' 'libarchive' 'wget')
-makedepends=('boost' 'tdb' 'cmake' 'git')
-md5sums=('3f7f705dc151b33742e888bcef17b58b')
-install='command-not-found.install'
-source=("https://github.com/metti/command-not-found/archive/v${pkgver}.zip")
+depends=('boost-libs'
+ 'libarchive'
+ 'tdb'
+ 'wget')
+makedepends=('boost'
+ 'cmake'
+ 'git')
+md5sums=('e991b83a0f0a65b4180683cd04c845e5')
+install=$pkgname.install
+source=("$url/archive/v$pkgver.zip")
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- cmake -D CMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="" src
+ cd $pkgname-$pkgver
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="" \
+ src
make
}
package(){
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
diff --git a/command-not-found.install b/command-not-found.install
index 26f49fa50086..09d4d2f46b10 100644
--- a/command-not-found.install
+++ b/command-not-found.install
@@ -11,4 +11,3 @@ pre_remove() {
rm -rf /var/lib/cnf/*.tdb
}
-# vim:set ts=2 sw=2 et: