summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0b296fdae60..0d1202e56c52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
-# Generated by mksrcinfo v8
-# Wed Feb 22 17:26:13 UTC 2017
pkgbase = communi-desktop
pkgdesc = An IRC client for desktop environments.
- pkgver = 3.5.0
+ pkgver = 3.6.0
pkgrel = 1
url = https://communi.github.io/
install = .INSTALL
arch = x86_64
arch = i686
- license = GPL
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = BSD
+ makedepends = chrpath
depends = qt5-x11extras
depends = qt5-multimedia
depends = hicolor-icon-theme
depends = xdg-utils
depends = libcommuni
- source = communi-desktop-v3.5.0.tar.gz::https://github.com/communi/communi-desktop/archive/v3.5.0.tar.gz
- source = communi-shared-v3.5.0.tar.gz::https://github.com/communi/communi-shared/archive/v3.5.0.tar.gz
- md5sums = 5fd5d87a9f4ecdce86a7004915b3f094
- md5sums = 1f23bf566b7f676e041c9bfaa458e014
+ source = communi-desktop-v3.6.0.tar.gz::https://github.com/communi/communi-desktop/archive/v3.6.0.tar.gz
+ source = communi-shared-v3.6.0.tar.gz::https://github.com/communi/communi-shared/archive/v3.6.0.tar.gz
+ md5sums = 97764bc84a7c80c7d7f6724b6106fb03
+ md5sums = 379ca7959c9b8e1d4a004b29e1ad768f
pkgname = communi-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 4610fe969ebd..3974fc6af1e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,20 @@
# Maintainer: Stephen Brennan <smb196@case.edu>
+# Contributor: Arvedui <arvedui@posteo.de>
pkgname=communi-desktop
-pkgver=3.5.0
+pkgver=3.6.0
pkgrel=1
-epoch=
pkgdesc="An IRC client for desktop environments."
-arch=('x86_64' 'i686')
+arch=('x86_64' 'i686' 'aarch64' 'arm' 'armv6h' 'armv7h')
url="https://communi.github.io/"
-license=('GPL')
-groups=()
+license=('BSD')
depends=('qt5-x11extras' 'qt5-multimedia' 'hicolor-icon-theme' 'xdg-utils' 'libcommuni')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
+makedepends=('chrpath')
install=.INSTALL
-changelog=
source=("communi-desktop-v$pkgver.tar.gz::https://github.com/communi/$pkgname/archive/v$pkgver.tar.gz"
"communi-shared-v$pkgver.tar.gz::https://github.com/communi/communi-shared/archive/v$pkgver.tar.gz")
noextract=()
-md5sums=("5fd5d87a9f4ecdce86a7004915b3f094"
- "1f23bf566b7f676e041c9bfaa458e014")
+md5sums=("97764bc84a7c80c7d7f6724b6106fb03"
+ "379ca7959c9b8e1d4a004b29e1ad768f")
validpgpkeys=()
prepare() {
@@ -46,4 +37,6 @@ check() {
package() {
cd "$pkgname-$pkgver"
make INSTALL_ROOT="$pkgdir" install
+
+ chrpath -d "${pkgdir}/usr/bin/communi"
}