summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
-rw-r--r--compact-steam-skin.install11
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d003447c060
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = compact-steam-skin
+ pkgdesc = A compact skin for steam
+ pkgver = 1.6.53
+ pkgrel = 1
+ url = https://github.com/badanka/Compact
+ install = compact-steam-skin.install
+ arch = any
+ license = unknown
+ depends = steam
+ depends = sssm
+ source = https://github.com/badanka/Compact/archive/1.6.53.zip
+ md5sums = 9109ad069130c16a3641ac4a23bcabbe
+
+pkgname = compact-steam-skin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14457e1c01aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: barfin
+pkgname=compact-steam-skin
+pkgver=1.6.53
+pkgrel=1
+pkgdesc="A compact skin for steam"
+arch=("any")
+url="https://github.com/badanka/Compact"
+license=('unknown')
+depends=("steam" "sssm")
+source=("${url}/archive/${pkgver}.zip")
+md5sums=('9109ad069130c16a3641ac4a23bcabbe')
+install="${pkgname}.install"
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/steam/skins"
+ mv "${srcdir}/Compact-${pkgver}" "${srcdir}/Compact"
+ cp -r "${srcdir}/Compact" "${pkgdir}/usr/share/steam/skins"
+}
diff --git a/compact-steam-skin.install b/compact-steam-skin.install
new file mode 100644
index 000000000000..f23e6cc7377f
--- /dev/null
+++ b/compact-steam-skin.install
@@ -0,0 +1,11 @@
+post_install() {
+ /usr/bin/sssm sync Compact
+}
+
+post_upgrade() {
+ /usr/bin/sssm sync Compact
+}
+
+post_remove() {
+ /usr/bin/sssm remove Compact
+}