summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD42
2 files changed, 55 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c2184c0e47e..b61070227b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jul 15 20:16:14 UTC 2016
+# Tue Apr 4 20:03:53 UTC 2017
pkgbase = compiz-core-git
pkgdesc = This is the latest git release of Compiz without DE deps
- pkgver = 0.8.12.3.r24.g292d9a2
- pkgrel = 2
+ pkgver = 0.8.12.3.r84.g20335d7d
+ pkgrel = 1
url = https://github.com/compiz-reloaded/compiz
arch = i686
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = compiz-core-git
depends = libsm
depends = libxcomposite
depends = libxinerama
- provides = compiz-core=0.8.12.3.r24.g292d9a2
+ provides = compiz-core=0.8.12.3.r84.g20335d7d
options = !libtool
options = !emptydirs
source = git+https://github.com/compiz-reloaded/compiz.git
@@ -29,7 +29,19 @@ pkgbase = compiz-core-git
pkgname = compiz-core-git
pkgdesc = This is the latest git release of Compiz without DE deps (Core w/o decorator)
- provides = compiz-core=0.8.12.3.r24.g292d9a2
+ depends = startup-notification
+ depends = librsvg
+ depends = dbus
+ depends = glu
+ depends = libxslt
+ depends = libxrandr
+ depends = libsm
+ depends = libxcomposite
+ depends = libxinerama
+ depends = hicolor-icon-theme
+ depends = libxi
+ depends = libxcursor
+ provides = compiz-core=0.8.12.3.r84.g20335d7d
conflicts = compiz
conflicts = compiz-core
@@ -44,7 +56,11 @@ pkgname = compiz-gtk-git
depends = libsm
depends = libxcomposite
depends = libxinerama
- depends = gtk2
- provides = compiz-gtk=0.8.12.3.r24.g292d9a2
+ depends = compiz-core-git
+ depends = marco-gtk2
+ depends = marco
+ depends = libwnck3
+ depends = libwnck
+ provides = compiz-gtk=0.8.12.3.r84.g20335d7d
conflicts = compiz-gtk
diff --git a/PKGBUILD b/PKGBUILD
index 620527b2529f..6763c2663601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,19 @@
# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
# Contributor: martadinata666 <martadinata666@gmail.com>
+# Flag for whether to use marco
_use_marco=0
+# Flag for whether to use GTK+3
+# Autoset depending on marco option
+_use_gtk3=0
+
_upstream="compiz"
pkgbase=compiz-core-git
pkgname=(compiz-core-git compiz-gtk-git)
-pkgver=0.8.12.3.r24.g292d9a2
-pkgrel=2
+pkgver=0.8.12.3.r84.g20335d7d
+pkgrel=1
pkgdesc="This is the latest git release of Compiz without DE deps"
url="https://github.com/compiz-reloaded/${_upstream}"
license=('GPL' 'LGPL' 'MIT')
@@ -37,16 +42,25 @@ _configure_opts=(
if (("${_use_marco}" == 1));then
_configure_opts+=("--enable-marco")
makedepends+=("marco")
- msg "Marco theme support enabled"
+ _use_gtk3=1
+ msg "Marco theme support enabled with GTK+3"
elif (("${_use_marco}" == 2));then
_configure_opts+=("--enable-marco")
- _configure_opts+=("--with-gtk=3.0")
- makedepends+=("marco-gtk3")
- msg "Marco theme support enabled with GTK+3"
+ makedepends+=("marco-gtk2")
+ _use_gtk3=0
+ msg "Marco theme support enabled with GTK+2"
else
_configure_opts+=("--disable-marco")
msg "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it"
- msg "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk3"
+ msg "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk2"
+fi
+
+if (("${_use_gtk3}" >= 1)); then
+ _configure_opts+=("--with-gtk=3.0")
+ msg "Using GTK+3 for gtk-window-decorator"
+else
+ _configure_opts+=("--with-gtk=2.0")
+ msg "Using GTK+2 for gtk-window-decorator"
fi
pkgver() {
@@ -74,6 +88,7 @@ package_compiz-core-git() {
cd "$srcdir/${_upstream}"
pkgdesc+=" (Core w/o decorator)"
+ depends+=('hicolor-icon-theme' 'libxi' 'libxcursor')
provides=("compiz-core=$pkgver")
conflicts=('compiz' 'compiz-core')
@@ -95,14 +110,21 @@ package_compiz-core-git() {
package_compiz-gtk-git()
{
+ depends+=('compiz-core-git')
#separating libmarco-private would be nice, but this is a workaround for now
if (("${_use_marco}" == 1));then
- depends+=('marco')
+ depends+=('marco-gtk2')
elif (("${_use_marco}" == 2));then
- depends+=('marco-gtk3')
+ depends+=('marco')
+ fi
+
+ if (( "${_use_gtk3}" >= 1 ));then
+ depends+=('libwnck3')
else
- depends+=('gtk2')
+ depends+=('libwnck')
fi
+
+
pkgdesc+=" (GTK+ window decorator)"
provides=("compiz-gtk=$pkgver")
conflicts=('compiz-gtk')