summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
3 files changed, 41 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fed9667f1596..a71e41abf2a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Apr 11 23:27:38 UTC 2016
+# Sat May 7 21:49:16 UTC 2016
pkgbase = compiz-core-git
pkgdesc = This is the latest git release of Compiz without DE deps
pkgver = 0.8.12.3.r0.g59328f2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/compiz-reloaded/compiz
arch = i686
arch = x86_64
@@ -44,6 +44,7 @@ pkgname = compiz-gtk-git
depends = libsm
depends = libxcomposite
depends = libxinerama
+ depends = gtk2
provides = compiz-gtk=0.8.12.3.r0.g59328f2
conflicts = compiz-gtk
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index aa1bd5946896..493f568f06de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _upstream="compiz"
pkgbase=compiz-core-git
pkgname=(compiz-core-git compiz-gtk-git)
pkgver=0.8.12.3.r0.g59328f2
-pkgrel=1
+pkgrel=2
pkgdesc="This is the latest git release of Compiz without DE deps"
url="https://github.com/compiz-reloaded/${_upstream}"
license=('GPL' 'LGPL' 'MIT')
@@ -54,6 +54,12 @@ build()
NOCONFIGURE=1 ./autogen.sh
./configure "${_configure_opts[@]}"
+ if ! grep -q pkg_cv_GTK config.log;then
+ # make sure only compiz-core-git is created if gtk is missing
+ msg "Making sure only $pkgbase is made, gtk+2 is missing"
+ pkgname=("$pkgbase")
+ fi
+
make
}
@@ -65,9 +71,19 @@ package_compiz-core-git() {
conflicts=('compiz' 'compiz-core')
make DESTDIR="$pkgdir" install
- rm "${pkgdir}/usr/bin/gtk-window-decorator"
- rm "${pkgdir}/usr/share/glib-2.0/schemas/org.compiz-0.gwd.gschema.xml"
- rm "${pkgdir}/usr/share/icons/hicolor/"*"/apps/gtk-decorator."*
+
+ local REMOVE_THESE=(
+ "${pkgdir}/usr/bin/gtk-window-decorator"
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.compiz-0.gwd.gschema.xml"
+ "${pkgdir}/usr/share/icons/hicolor/"*"/apps/gtk-decorator."*
+ )
+ # Believe it or not, you CAN fill an array using wildcards in bash
+
+ for fname in "${REMOVE_THESE[@]}";do
+ if [ -e "$fname" ];then
+ rm "$fname"
+ fi
+ done
}
package_compiz-gtk-git()
@@ -75,6 +91,8 @@ package_compiz-gtk-git()
if (("${_use_marco}"));then
#separating libmarco-private would be nice, but this is a workaround for now
depends+=('marco')
+ else
+ depends+=('gtk2')
fi
pkgdesc+=" (GTK+ window decorator)"
provides=("compiz-gtk=$pkgver")
@@ -82,10 +100,20 @@ package_compiz-gtk-git()
cd "${srcdir}/${_upstream}/gtk"
make DESTDIR="${pkgdir}" install
- rm "${pkgdir}/usr/share/applications/compiz.desktop"
cd "${srcdir}/${_upstream}/images"
make DESTDIR="${pkgdir}" install
- rm "${pkgdir}/usr/share/icons/hicolor/"*"/apps/compiz."*
- rm "${pkgdir}/usr/share/compiz/"*.png
+
+ local REMOVE_THESE=(
+ "${pkgdir}/usr/share/icons/hicolor/"*"/apps/compiz."*
+ "${pkgdir}/usr/share/compiz/"*.png
+ "${pkgdir}/usr/share/applications/compiz.desktop"
+ )
+ # Believe it or not, you CAN fill an array using wildcards in bash
+
+ for fname in "${REMOVE_THESE[@]}";do
+ if [ -e "$fname" ];then
+ rm "$fname"
+ fi
+ done
}