summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 775011ea31a3..8d55fa3d2678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
-# Maintainer: c0ldcat <firez199984@gmail.com>
+# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=con2fbmap
-pkgver=2.1
-pkgrel=28
-pkgdesc="Shows and sets mapping between consoles and framebuffer devices"
-url="http://debian.org"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-source=("http://ftp.lanet.kr/debian/pool/main/f/fbset/fbset_2.1-28.debian.tar.xz")
-md5sums=("deb9d0590d660ac8cd871fe8d84072a0")
+pkgver=2.1.0
+pkgrel=50
+pkgdesc='Shows and sets mapping between consoles and framebuffer devices'
+url='https://www.debian.org/'
+license=('GPL')
+arch=('any')
+source=('https://mirrors.kernel.org/debian/pool/main/f/fbset/fbset_2.1-28.debian.tar.xz')
+sha512sums=('ea96e699e08d15fec4106434edf6f360e78e531dbbd81507bca8f2b31ec39fd12ba0d5c4a6c8a8a110112f3d4e83c3425ebaa59625adb24c3990d18e6f2051c9')
-package() {
+prepare() {
+ cd "${srcdir}"
+ patch -N --silent -p0 -i debian/patches/03_con2fbmap.patch &2>/dev/null
+}
+
+build() {
cd "${srcdir}"
- patch -i debian/patches/03_con2fbmap.patch
gcc con2fbmap.c -o con2fbmap
- install -Dm755 con2fbmap ${pkgdir}/usr/bin/con2fbmap
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 con2fbmap "${pkgdir}/usr/bin/con2fbmap"
}