summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD57
-rw-r--r--machdefs.h.patch11
5 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5ed36ef0e7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = concorde
+ pkgdesc = Travelling Salesman Problem Solver
+ pkgver = 03.12.19
+ pkgrel = 1
+ url = http://www.math.uwaterloo.ca/tsp/concorde/index.html
+ arch = x86_64
+ license = custom
+ depends = cplex
+ options = !buildflags
+ source = http://www.math.uwaterloo.ca/tsp/concorde/downloads/codes/src/co031219.tgz
+ source = machdefs.h.patch
+ source = LICENSE
+ sha256sums = c3650a59c8d57e0a00e81c1288b994a99c5aa03e5d96a314834c2d8f9505c724
+ sha256sums = b189efe02afc73af92ba61011debe35b099f3765d157d9e6e713d8725323be00
+ sha256sums = eb01297dfd2c9a1d6804e18a3af817bb3fa7b9e8b20628f71618f31cf7d7738c
+
+pkgname = concorde
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..02724694b06c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+*.tgz
+pkg/
+src/ \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..698f65531849
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+The full source code to the Concorde network optimization package,
+as well as executables for various platforms, and a Windows graphical
+user interface to Concorde's traveling salesman solver are available
+for academic research use; for other uses, contact William Cook for
+licensing options.
+
+###
+
+Text extracted from:
+http://www.math.uwaterloo.ca/tsp/concorde/downloads/downloads.htm
+
+"William Cook" links to the email:
+bico@uwaterloo.ca \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..155d48f49258
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Mantainer: Alberto Santini <alberto dot santini at upf dot edu>
+
+pkgname='concorde'
+pkgdesc='Travelling Salesman Problem Solver'
+
+pkgver='03.12.19'
+pkgrel='1'
+arch=('x86_64')
+url='http://www.math.uwaterloo.ca/tsp/concorde/index.html'
+license=('custom')
+depends=('cplex')
+options=('!buildflags')
+
+source=('http://www.math.uwaterloo.ca/tsp/concorde/downloads/codes/src/co031219.tgz'
+ 'machdefs.h.patch'
+ 'LICENSE')
+
+sha256sums=('c3650a59c8d57e0a00e81c1288b994a99c5aa03e5d96a314834c2d8f9505c724'
+ 'b189efe02afc73af92ba61011debe35b099f3765d157d9e6e713d8725323be00'
+ 'eb01297dfd2c9a1d6804e18a3af817bb3fa7b9e8b20628f71618f31cf7d7738c')
+
+prepare() {
+ cd "$srcdir/concorde"
+
+ mkdir -p local_cplex
+ cd local_cplex
+
+ ln -fs /usr/include/ilcplex/* .
+ ln -fs /usr/lib/libcplex.a .
+
+ cd ..
+
+ # Apply patch to fix an API-breaking change in recent Cplex versions
+ patch -p0 < "$srcdir/machdefs.h.patch"
+}
+
+build() {
+ cd "$srcdir/concorde"
+ ./configure --with-cplex="$srcdir/concorde/local_cplex" --enable-pthreads --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/concorde"
+
+ install -dm755 "$pkgdir/usr/bin"
+ install -m755 "TSP/concorde" "$pkgdir/usr/bin"
+
+ install -dm755 "$pkgdir/usr/include"
+ install -m644 concorde.h "$pkgdir/usr/include"
+
+ install -dm755 "$pkgdir/usr/lib"
+ install -m755 concorde.a "$pkgdir/usr/lib/libconcorde.a"
+
+ install -dm755 "$pkgdir/usr/share/doc/concorde"
+ install -m644 README "$pkgdir/usr/share/doc/concorde"
+}
diff --git a/machdefs.h.patch b/machdefs.h.patch
new file mode 100644
index 000000000000..2c5b6085b50e
--- /dev/null
+++ b/machdefs.h.patch
@@ -0,0 +1,11 @@
+--- INCLUDE/machdefs.h.orig 2018-08-12 15:22:12.796641255 +0200
++++ INCLUDE/machdefs.h 2018-08-12 15:22:56.589974125 +0200
+@@ -181,4 +181,8 @@
+
+ #endif
+
++#ifndef CPX_PARAM_FASTMIP
++#define CPX_PARAM_FASTMIP 1017
++#endif
++
+ #endif /* __MACHDEFS_H */