summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d15f49d64afd..103a06822175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Oct 1 06:15:42 UTC 2017
pkgbase = concourse-bin
pkgdesc = Concourse is a pipeline-based CI system written in Go.
pkgver = v3.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://concourse.ci/introduction.html
arch = x86_64
license = Apache
- depends = linux-userns
+ optdepends = linux-userns: user namespaces support (AUR, long build time)
+ optdepends = linux-zen: user namespaces support (extra, prebuilt)
provides = concourse
+ replaces = concourse
source = concourse-v3.5.0::https://github.com/concourse/concourse/releases/download/v3.5.0/concourse_linux_amd64
sha512sums = 2fa82213e009dea8f0369aea4a330c33a955c1c27421926211c9d43c8f69dab024014174b534b9d494f5eaad48dce3621dee99ce1f887c7a12de36fb905d5b3e
diff --git a/PKGBUILD b/PKGBUILD
index c5b4bbdca18a..8f8334648cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: Bram Swenson <bram@amplified.work>
+# Maintainer: Bram Swenson <bram at amplified dot work>
+# Maintainer: pancho horrillo <pancho at pancho dot name>
-pkgname_base='concourse'
-pkgname="${pkgname_base}-bin"
+_pkgname='concourse'
+pkgname="${_pkgname}-bin"
pkgver=v3.5.0
-pkgrel=1
-pkgdesc="Concourse is a pipeline-based CI system written in Go."
+pkgrel=2
+pkgdesc='Concourse is a pipeline-based CI system written in Go.'
arch=(x86_64)
-url="https://concourse.ci/introduction.html"
+url='https://concourse.ci/introduction.html'
license=('Apache')
-source=(concourse-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/concourse_linux_amd64)
+provides=("${_pkgname}")
+replaces=("${_pkgname}")
+optdepends=(
+ 'linux-userns: user namespaces support (AUR, long build time)'
+ 'linux-zen: user namespaces support (extra, prebuilt)'
+)
+source=("${_pkgname}-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/concourse_linux_amd64")
sha512sums=('2fa82213e009dea8f0369aea4a330c33a955c1c27421926211c9d43c8f69dab024014174b534b9d494f5eaad48dce3621dee99ce1f887c7a12de36fb905d5b3e')
-provides=('concourse')
-depends=('linux-userns')
package() {
- install -Dm755 "concourse-${pkgver}" "$pkgdir/usr/bin/concourse"
+ install -Dm755 "${_pkgname}-${pkgver}" "$pkgdir/usr/bin/concourse"
}