summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da3c68865883
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = confedi-git-bin
+ pkgdesc = Confedi is designed to help with changing configuration files with one command.
+ pkgver = 1
+ pkgrel = 1
+ url = https://bitbucket.org/masterofhoppips/configuration-editor.git
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python3
+ source = git+https://bitbucket.org/masterofhoppips/configuration-editor.git
+
+pkgname = confedi-git-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e08894513214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=confedi-git-bin
+pkgver=1
+pkgrel=1
+pkgdesc="Confedi is designed to help with changing configuration files with one command."
+arch=(any)
+license=('GPL')
+depends=(python3)
+makedepends=(git)
+url="https://bitbucket.org/masterofhoppips/configuration-editor.git"
+source=("git+$url")
+
+build(){
+ pyinstaller program.py -F
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ cp configuration-editor/src/dist/program "$pkgdir"/usr/bin/$pkgname
+}