summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9396c9de4e6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = confusion-mdl
+ pkgdesc = A MDL interpreter
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://gitlab.com/emacsomancer/confusion-mdl
+ arch = x86_64
+ license = GPL
+ provides = confusion
+ source = git+https://gitlab.com/emacsomancer/confusion-mdl.git
+ md5sums = SKIP
+
+pkgname = confusion-mdl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bf9730cb19d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# maintainer: libele <libele@disroot.org>
+# http://rec.arts.int-fiction.narkive.com/pM8Kgfbw/confusion-just-enough-mdl
+
+pkgname=confusion-mdl
+pkgver=0.2
+pkgrel=1
+pkgdesc="A MDL interpreter"
+arch=('x86_64')
+provides=('confusion')
+url='http://gitlab.com/emacsomancer/confusion-mdl'
+license=('GPL')
+source=("git+https://gitlab.com/emacsomancer/confusion-mdl.git")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}"/"${pkgname}"
+
+ make
+
+ install -Dm755 mdli "${pkgdir}"/usr/bin/mdli
+ ln -s /usr/bin/mdli "${pkgdir}"/usr/bin/confusion
+
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}