summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch54
-rw-r--r--PKGBUILD14
3 files changed, 68 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 241d788381a5..da8e6f4eda66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = congruity
pkgdesc = A GUI application for programming Logitech(R) Harmony(TM) remote controls.
pkgver = 18
- pkgrel = 2
+ pkgrel = 3
url = http://congruity.sourceforge.net/
install = congruity.install
arch = any
@@ -11,7 +11,9 @@ pkgbase = congruity
depends = python-libconcord>=1.1
depends = wxpython2.8
source = http://downloads.sourceforge.net/project/congruity/congruity/18/congruity-18.tar.bz2
+ source = 0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch
sha256sums = 16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878
+ sha256sums = fea8bbb603929afb743beb695de73809e606fa9d24e5810ae34ee72117317245
pkgname = congruity
diff --git a/0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch b/0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch
new file mode 100644
index 000000000000..b923948d604d
--- /dev/null
+++ b/0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch
@@ -0,0 +1,54 @@
+From 9ae53766b3a3344653c9f9bc9be1ea36f81eadd3 Mon Sep 17 00:00:00 2001
+From: Scott Talbert <swt@techie.net>
+Date: Sat, 20 Jun 2015 13:55:53 -0400
+Subject: [PATCH] Fix mhgui for SupportedCapabilities change in web service
+
+NOTE: this patch will need to be cherry-picked by distributions to
+keep mhgui functional.
+---
+ mhgui | 4 ++--
+ mhmanager.py | 6 ++++++
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/mhgui b/mhgui
+index 090722e..10cac18 100755
+--- a/mhgui
++++ b/mhgui
+@@ -629,7 +629,7 @@ class RemoteConfigurationPanel(WizardPanelBase):
+
+ # Populate remote-specific buttons in rightButtonSizer
+ self.rightButtonSizer.Clear(deleteWindows=True)
+- capabilities = self.product.SupportedCapabilities.SupportedCapability
++ capabilities = mhMgr.GetCapabilityNames(self.product)
+ if "FavoriteChannels" in capabilities:
+ self.AddFavoriteChannelsButton()
+ if "CompiledRemoteButtonMapping" in capabilities or \
+@@ -1316,7 +1316,7 @@ class ConfigureDevicePanel(WizardPanelBase):
+ # Only populate the buttons list if this remote has buttons; if the
+ # 'remote' is a Harmony Link, it has no ProductButtonList.
+ self.remoteButtons = None
+- capabilities = self.product.SupportedCapabilities.SupportedCapability
++ capabilities = mhMgr.GetCapabilityNames(self.product)
+ if "CompiledRemoteButtonMapping" in capabilities:
+ self.remoteButtons = mhMgr.GetProductButtonList(self.skinId)
+ self.deviceCommands = mhMgr.GetCommands(self.deviceId)
+diff --git a/mhmanager.py b/mhmanager.py
+index 791e03a..cace8e9 100644
+--- a/mhmanager.py
++++ b/mhmanager.py
+@@ -207,6 +207,12 @@ class MHManager():
+ def GetProductButtonList(self, skinId):
+ return self.client.service['ProductsManager'].GetProductButtonList(skinId).Buttons.ButtonDefinition
+
++ def GetCapabilityNames(self, product):
++ capabilityNames = []
++ for capability in product.SupportedCapabilities.ProductCapability:
++ capabilityNames.append(capability.Name)
++ return capabilityNames
++
+ def GetCommands(self, deviceId):
+ deviceIds = self.client.factory.create('{' + DATA_NS + '}deviceIds')
+ deviceIds.DeviceId.append(deviceId)
+--
+2.5.0
+
diff --git a/PKGBUILD b/PKGBUILD
index f149721d3954..f0209f1cf37f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,26 @@
pkgname=congruity
pkgver=18
-pkgrel=2
+pkgrel=3
pkgdesc='A GUI application for programming Logitech(R) Harmony(TM) remote controls.'
arch=('any')
url='http://congruity.sourceforge.net/'
license=('GPL3')
depends=('desktop-file-utils' 'python2-suds' 'python-libconcord>=1.1' 'wxpython2.8')
install="$pkgname.install"
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878')
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+ "0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch")
+sha256sums=('16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878'
+ 'fea8bbb603929afb743beb695de73809e606fa9d24e5810ae34ee72117317245')
package() {
cd "$srcdir/$pkgname-$pkgver"
+
+ msg "Patching..."
+ for i in $srcdir/*.patch; do
+ patch -Np1 -i "$i"
+ done
+
sed -i 's@wxversion.ensureMinimal@wxversion.select@g' congruity mhgui
sed -i 's@#!/usr/bin/env python@#!/usr/bin/env python2@g' congruity mhgui
sed -i 's@#!/usr/bin/python@#!/usr/bin/env python2@g' mhmanager.py