summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--curl.patch14
-rw-r--r--ipv6.patch28
4 files changed, 59 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f57365402f9..68dc96ab25ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-cli
pkgdesc = Lightweight system monitor for X, without X11 dependencies
pkgver = 1.10.0
- pkgrel = 1
+ pkgrel = 2
url = http://conky.sourceforge.net/
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = conky-cli
makedepends = cmake
makedepends = docbook2x
makedepends = docbook-xml
+ makedepends = docbook-xsl
makedepends = man-db
depends = curl
depends = lua
@@ -20,9 +21,13 @@ pkgbase = conky-cli
source = https://github.com/brndnmtthws/conky/archive/v1.10.0.tar.gz
source = ascii.patch
source = lua53.patch
+ source = ipv6.patch
+ source = curl.patch
md5sums = cdc0298e5f257829d574ae8114170d9b
md5sums = d5b765cb7400d2fdca88b6c86aa8eec1
md5sums = 44cdadfe92266e99698e5424b7c6e265
+ md5sums = 702650dfaaacb4e778f3d3c6a296df0b
+ md5sums = 8236606ca3d39b9d00a59022d4f953ac
pkgname = conky-cli
diff --git a/PKGBUILD b/PKGBUILD
index 14c6bae4297f..14eccdda3ca2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,26 +6,32 @@
_pkgname=conky
pkgname=conky-cli
pkgver=1.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight system monitor for X, without X11 dependencies"
-url="http://conky.sourceforge.net/"
+url='http://conky.sourceforge.net/'
license=('BSD' 'GPL')
arch=('i686' 'x86_64')
provides=('conky')
conflicts=('conky')
-makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db')
+makedepends=('cmake' 'docbook2x' 'docbook-xml' 'docbook-xsl' 'man-db')
depends=('curl' 'lua' 'wireless_tools' 'libxml2')
source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
'ascii.patch'
- 'lua53.patch')
+ 'lua53.patch'
+ 'ipv6.patch'
+ 'curl.patch')
md5sums=('cdc0298e5f257829d574ae8114170d9b'
'd5b765cb7400d2fdca88b6c86aa8eec1'
- '44cdadfe92266e99698e5424b7c6e265')
+ '44cdadfe92266e99698e5424b7c6e265'
+ '702650dfaaacb4e778f3d3c6a296df0b'
+ '8236606ca3d39b9d00a59022d4f953ac')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i ../ascii.patch # db2x_manxml fails on non-ascii chars
patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
+ patch -p1 -i ../ipv6.patch # https://bugs.archlinux.org/task/45626
+ patch -p1 -i ../curl.patch # https://github.com/bagder/curl/issues/342
}
build() {
diff --git a/curl.patch b/curl.patch
new file mode 100644
index 000000000000..f5aad6532075
--- /dev/null
+++ b/curl.patch
@@ -0,0 +1,14 @@
+diff -Naur old/src/ccurl_thread.cc new/src/ccurl_thread.cc
+--- old/src/ccurl_thread.cc 2015-06-21 14:49:06.000000000 -1000
++++ new/src/ccurl_thread.cc 2015-07-11 09:11:49.053040998 -1000
+@@ -119,9 +119,7 @@
+ headers.h = curl_slist_append(headers.h, ("If-None-Match: " + etag).c_str());
+ etag.clear();
+ }
+- if (headers.h) {
+- curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
+- }
++ curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
+
+ res = curl_easy_perform(curl);
+ if (res == CURLE_OK) {
diff --git a/ipv6.patch b/ipv6.patch
new file mode 100644
index 000000000000..7135ae708308
--- /dev/null
+++ b/ipv6.patch
@@ -0,0 +1,28 @@
+From ee08a9e1b045e8d2f4f13a0e60c2f603b66b0d69 Mon Sep 17 00:00:00 2001
+From: Marc Payne <marc321@gmail.com>
+Date: Mon, 6 Jul 2015 02:51:43 -0600
+Subject: [PATCH] Close file only if it was successfully opened
+
+If BUILD_IPV6=ON (default), but the user has disabled ipv6 support
+in the kernel using the parameter ipv6.disable=1, then conky fails
+to open /proc/net/if_inet6. This leads to a segfault when conky
+calls fclose(file) regardless. This fix simply moves the fclose call
+into the preceding if statement.
+---
+ src/linux.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/linux.cc b/src/linux.cc
+index 847acac..7977fee 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -643,8 +643,8 @@ int update_net_stats(void)
+ }
+ lastv6->next = NULL;
+ }
++ fclose(file);
+ }
+- fclose(file);
+ #endif /* BUILD_IPV6 */
+
+ first = 0;