summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD52
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f3e11107230
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = conky-git
+ pkgdesc = Lightweight system monitor for X
+ pkgver = 1.999.r481.g3414955
+ pkgrel = 1
+ url = http://conky.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = GPL
+ makedepends = cmake
+ makedepends = docbook2x
+ makedepends = docbook-xml
+ makedepends = man-db
+ makedepends = git
+ depends = glib2
+ depends = curl
+ depends = lua
+ depends = wireless_tools
+ depends = libxml2
+ depends = libxft
+ depends = libxdamage
+ depends = imlib2
+ provides = conky
+ conflicts = conky
+ options = !strip
+ options = debug
+ source = conky::git+https://github.com/brndnmtthws/conky.git
+ sha1sums = SKIP
+
+pkgname = conky-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf0eb6d56b39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Beini <bane@iki.fi>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+
+pkgname=conky-git
+pkgver=1.999.r481.g3414955
+pkgrel=1
+pkgdesc='Lightweight system monitor for X'
+url='http://conky.sourceforge.net/'
+license=('BSD' 'GPL')
+arch=('i686' 'x86_64')
+makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db' 'git')
+depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')
+provides=("conky")
+conflicts=('conky')
+source=('conky::git+https://github.com/brndnmtthws/conky.git')
+sha1sums=('SKIP')
+
+options=('!strip' 'debug')
+
+pkgver() {
+ cd conky
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd conky
+
+ cmake \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D MAINTAINER_MODE=ON \
+ -D BUILD_CURL=ON \
+ -D BUILD_XDBE=ON \
+ -D BUILD_IMLIB2=ON \
+ -D BUILD_RSS=ON \
+ -D BUILD_WEATHER_METAR=ON \
+ -D BUILD_WEATHER_XOAP=ON \
+ -D BUILD_WLAN=ON \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ .
+
+ make
+}
+
+package() {
+ cd conky
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
+ install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
+}