summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rwxr-xr-xprepare4uploadpkg.sh2
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 877da307dd72..6f2c9172e57d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = conky-lua-archers
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
- pkgver = 1.10.8
+ pkgver = 1.11.0
pkgrel = 1
url = https://github.com/brndnmtthws/conky
arch = i686
@@ -23,11 +23,10 @@ pkgbase = conky-lua-archers
depends = libxft
depends = libxinerama
depends = libxml2
- depends = libxnvctrl
depends = lua51
depends = tolua++
depends = wireless_tools
- provides = conky=1.10.8
+ provides = conky=1.11.0
conflicts = conky
conflicts = conky-lua
conflicts = conky-lua-arch
@@ -37,8 +36,9 @@ pkgbase = conky-lua-archers
replaces = conky
options = strip
options = !debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.8.tar.gz
- sha256sums = 2ebd655a27c816bd613538b71d4ec1c096252cb522feaa05f64781dcedea8857
+ options = !emptydirs
+ source = https://github.com/brndnmtthws/conky/archive/v1.11.0.tar.gz
+ sha256sums = cc75b5f6cdeefa83082f3dedf5a12105569c2cdc0ae3e7728922d79bc4abcf51
pkgname = conky-lua-archers
diff --git a/PKGBUILD b/PKGBUILD
index c4470ee296e5..15d83198815a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=conky-lua-archers
_pkgname=conky
-pkgver=1.10.8
+pkgver=1.11.0
pkgrel=1
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
@@ -24,11 +24,11 @@ depends=(
'libxft'
'libxinerama'
'libxml2'
- 'libxnvctrl'
'lua51'
'tolua++'
'wireless_tools'
)
+# 'libxnvctrl'
makedepends=(
'cmake'
'docbook2x'
@@ -38,8 +38,8 @@ makedepends=(
'perl-xml-sax-expat'
)
source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('2ebd655a27c816bd613538b71d4ec1c096252cb522feaa05f64781dcedea8857')
-options=('strip' '!debug')
+sha256sums=('cc75b5f6cdeefa83082f3dedf5a12105569c2cdc0ae3e7728922d79bc4abcf51')
+options=('strip' '!debug' '!emptydirs')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -65,7 +65,6 @@ build() {
-D BUILD_LUA_RSVG=ON \
-D BUILD_MOC=OFF \
-D BUILD_MPD=OFF \
- -D BUILD_NVIDIA=ON \
-D BUILD_OLD_CONFIG=ON \
-D BUILD_PULSEAUDIO=ON \
-D BUILD_WLAN=ON \
@@ -79,6 +78,7 @@ build() {
.
make
}
+# -D BUILD_NVIDIA=ON \
package() {
cd ${srcdir}/${_pkgname}-${pkgver}
diff --git a/prepare4uploadpkg.sh b/prepare4uploadpkg.sh
index 1e00c9a35b71..240961110633 100755
--- a/prepare4uploadpkg.sh
+++ b/prepare4uploadpkg.sh
@@ -2,7 +2,7 @@
namcap PKGBUILD && makepkg --printsrcinfo > .SRCINFO || exit 1
git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
-git commit -am "New package commit" || exit 1
+git commit -am "No Nvidia support, yet?" || exit 1
git push --set-upstream origin master || exit 1
read -p "Press [Enter] key to exit..."