summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
-rw-r--r--asciime.patch12
3 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 129a60f1183f..7c6390328382 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-archers-git
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
pkgver = 3145.3b4b9ab
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/brndnmtthws/conky/
arch = i686
arch = x86_64
@@ -11,8 +11,9 @@ pkgbase = conky-lua-archers-git
makedepends = docbook2x
makedepends = docbook-xml
makedepends = docbook-xsl
- makedepends = git
+ makedepends = man-db
makedepends = perl-xml-libxml
+ makedepends = perl-xml-sax-expat
depends = alsa-lib
depends = cairo
depends = curl
@@ -38,7 +39,9 @@ pkgbase = conky-lua-archers-git
options = !strip
options = debug
source = git://github.com/brndnmtthws/conky.git
+ source = asciime.patch
sha1sums = SKIP
+ sha1sums = b07407c2be11cee7bd50e046024b89cf2579c448
pkgname = conky-lua-archers-git
diff --git a/PKGBUILD b/PKGBUILD
index c9357063eb87..4e4b707a79ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
-# Maintainer : Yiannis A Ginis <drxspace[at]gmail[dot]com>
+# Maintainer : Yiannis A Ginis <drxspace[at]gmail[dot]com>
+# Contributor : Chris Sakalis <chrissakalis[at]gmail[dot]com>
+
pkgname=conky-lua-archers-git
_pkgname=conky
pkgver=3145.3b4b9ab
-pkgrel=1
+pkgrel=2
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky/"
@@ -31,11 +33,14 @@ makedepends=(
'docbook2x'
'docbook-xml'
'docbook-xsl'
- 'git'
+ 'man-db'
'perl-xml-libxml'
+ 'perl-xml-sax-expat'
)
-source=("git://github.com/brndnmtthws/${_pkgname}.git")
-sha1sums=('SKIP')
+source=("git://github.com/brndnmtthws/${_pkgname}.git"
+ 'asciime.patch')
+sha1sums=('SKIP'
+ 'b07407c2be11cee7bd50e046024b89cf2579c448')
options=('!strip' 'debug')
pkgver() {
@@ -45,7 +50,8 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- mkdir build/
+ patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
+ mkdir -p build/ # as afaikifreedom recommented
}
build() {
@@ -59,6 +65,7 @@ build() {
-D BUILD_ARGB=ON \
-D BUILD_CURL=ON \
-D BUILD_I18N=ON \
+ -D BUILD_IBM=OFF \
-D BUILD_IMLIB2=ON \
-D BUILD_IOSTATS=ON \
-D BUILD_IPV6=ON \
@@ -86,7 +93,7 @@ package() {
cd "${srcdir}/${_pkgname}/build"
make DESTDIR=${pkgdir} install
cd ..
- install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m644 LICENSE.GPL ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.GPL
install -D -m644 LICENSE.BSD ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.BSD
install -D -m644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
install -D -m644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
diff --git a/asciime.patch b/asciime.patch
new file mode 100644
index 000000000000..57725e153a9d
--- /dev/null
+++ b/asciime.patch
@@ -0,0 +1,12 @@
+diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
+--- unicode/doc/config_settings.xml 2016-07-20 19:53:48.000000000 +0300
++++ ascii/doc/config_settings-new.xml 2016-08-09 10:05:46.094287298 +0300
+@@ -80,7 +80,7 @@
+ </term>
+ <listitem>A comma-separated list of strings to use as the bars of a graph output
+ to console/shell. The first list item is used for the minimum bar height and the
+- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
++ last item is used for the maximum.
+ <para /></listitem>
+ </varlistentry>
+ <varlistentry>