summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--include.patch11
-rwxr-xr-xprepare4uploadpkg.sh10
4 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82a7680f6c0b..8e154873884a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-archers-git
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
pkgver = 3166.a58a6d4e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/brndnmtthws/conky/
arch = i686
arch = x86_64
@@ -39,8 +39,10 @@ pkgbase = conky-lua-archers-git
options = debug
source = git://github.com/brndnmtthws/conky.git
source = asciime.patch
+ source = include.patch
sha1sums = SKIP
sha1sums = b07407c2be11cee7bd50e046024b89cf2579c448
+ sha1sums = 0efe24eab88c48cc1fef0dae001ce935f743c131
pkgname = conky-lua-archers-git
diff --git a/PKGBUILD b/PKGBUILD
index 56d94f2d22c0..f47b6d52917c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=conky-lua-archers-git
_pkgname=conky
pkgver=3166.a58a6d4e
-pkgrel=1
+pkgrel=2
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky/"
@@ -37,9 +37,11 @@ makedepends=(
'perl-xml-sax-expat'
)
source=("git://github.com/brndnmtthws/${_pkgname}.git"
- 'asciime.patch')
+ 'asciime.patch'
+ 'include.patch')
sha1sums=('SKIP'
- 'b07407c2be11cee7bd50e046024b89cf2579c448')
+ 'b07407c2be11cee7bd50e046024b89cf2579c448'
+ '0efe24eab88c48cc1fef0dae001ce935f743c131')
options=('!strip' 'debug')
pkgver() {
@@ -50,11 +52,13 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
+ patch -p1 -i ../include.patch # Build fails with gcc7 due to missing include
mkdir -p build/ # as @afaikifreedom recommended
}
build() {
cd "${srcdir}/${_pkgname}/build"
+
cmake \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \
diff --git a/include.patch b/include.patch
new file mode 100644
index 000000000000..fd3afb89004c
--- /dev/null
+++ b/include.patch
@@ -0,0 +1,11 @@
+
+diff -bur conky-1.10.6-orig/src/luamm.hh conky-1.10.6/src/luamm.hh
+--- conky-1.10.6-orig/src/luamm.hh 2016-12-04 17:13:57.000000000 +0200
++++ conky-1.10.6/src/luamm.hh 2017-05-31 20:05:59.000000000 +0300
+@@ -28,6 +28,7 @@
+ #include <exception>
+ #include <stdexcept>
+ #include <string>
++#include <functional>
+
+ #include <lua.hpp>
diff --git a/prepare4uploadpkg.sh b/prepare4uploadpkg.sh
new file mode 100755
index 000000000000..934309fc5e6d
--- /dev/null
+++ b/prepare4uploadpkg.sh
@@ -0,0 +1,10 @@
+#!/usr/bin/env bash
+
+namcap PKGBUILD && makepkg --printsrcinfo > .SRCINFO || exit 1
+git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
+git commit -am "New package commit" || exit 1
+git push --set-upstream origin master || exit 1
+
+read -p "Press [Enter] key to exit..."
+
+exit $?