summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD12
-rw-r--r--include.patch11
-rwxr-xr-xprepare4uploadpkg.sh8
5 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e154873884a..a47b5b512158 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-archers-git
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
- pkgver = 3166.a58a6d4e
- pkgrel = 2
+ pkgver = 3169.262a2925
+ pkgrel = 1
url = https://github.com/brndnmtthws/conky/
arch = i686
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = conky-lua-archers-git
makedepends = docbook2x
makedepends = docbook-xml
makedepends = docbook-xsl
+ makedepends = git
makedepends = perl-xml-libxml
makedepends = perl-xml-sax-expat
depends = alsa-lib
@@ -39,10 +40,8 @@ pkgbase = conky-lua-archers-git
options = debug
source = git://github.com/brndnmtthws/conky.git
source = asciime.patch
- source = include.patch
sha1sums = SKIP
sha1sums = b07407c2be11cee7bd50e046024b89cf2579c448
- sha1sums = 0efe24eab88c48cc1fef0dae001ce935f743c131
pkgname = conky-lua-archers-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e50d7f964192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.diff
+!*.install
+!*.service
diff --git a/PKGBUILD b/PKGBUILD
index f47b6d52917c..5b7a9d78422b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=conky-lua-archers-git
_pkgname=conky
-pkgver=3166.a58a6d4e
-pkgrel=2
+pkgver=3169.262a2925
+pkgrel=1
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky/"
@@ -33,15 +33,14 @@ makedepends=(
'docbook2x'
'docbook-xml'
'docbook-xsl'
+ 'git'
'perl-xml-libxml'
'perl-xml-sax-expat'
)
source=("git://github.com/brndnmtthws/${_pkgname}.git"
- 'asciime.patch'
- 'include.patch')
+ 'asciime.patch')
sha1sums=('SKIP'
- 'b07407c2be11cee7bd50e046024b89cf2579c448'
- '0efe24eab88c48cc1fef0dae001ce935f743c131')
+ 'b07407c2be11cee7bd50e046024b89cf2579c448')
options=('!strip' 'debug')
pkgver() {
@@ -52,7 +51,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
- patch -p1 -i ../include.patch # Build fails with gcc7 due to missing include
mkdir -p build/ # as @afaikifreedom recommended
}
diff --git a/include.patch b/include.patch
deleted file mode 100644
index fd3afb89004c..000000000000
--- a/include.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-
-diff -bur conky-1.10.6-orig/src/luamm.hh conky-1.10.6/src/luamm.hh
---- conky-1.10.6-orig/src/luamm.hh 2016-12-04 17:13:57.000000000 +0200
-+++ conky-1.10.6/src/luamm.hh 2017-05-31 20:05:59.000000000 +0300
-@@ -28,6 +28,7 @@
- #include <exception>
- #include <stdexcept>
- #include <string>
-+#include <functional>
-
- #include <lua.hpp>
diff --git a/prepare4uploadpkg.sh b/prepare4uploadpkg.sh
index 934309fc5e6d..ac82dfe5b1e5 100755
--- a/prepare4uploadpkg.sh
+++ b/prepare4uploadpkg.sh
@@ -1,8 +1,12 @@
#!/usr/bin/env bash
+makepkg --nobuild --skipinteg
+
+rm -rf src/ conky*
+
namcap PKGBUILD && makepkg --printsrcinfo > .SRCINFO || exit 1
-git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
-git commit -am "New package commit" || exit 1
+git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
+git commit -am "New git commit" || exit 1
git push --set-upstream origin master || exit 1
read -p "Press [Enter] key to exit..."