summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD12
-rwxr-xr-xconlie.install35
-rwxr-xr-xlie4
5 files changed, 19 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d46534dabce5..16a440020001 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Mar 19 12:22:37 UTC 2016
pkgbase = conlie
- pkgdesc = A Computer algebra package for Lie group computations
+ pkgdesc = A Computer algebra package for Lie group computations (Compile only version)
pkgver = 2.2.2
- pkgrel = 2
+ pkgrel = 3
url = http://www-math.univ-poitiers.fr/~maavl/LiE/
- install = conlie.install
arch = i686
arch = x86_64
license = LGPL
- depends = readline
+ depends = sh
+ provides = lie
source = http://www-math.univ-poitiers.fr/~maavl/LiE/conLiE.tar.gz
+ source = http://wwwmathlabo.univ-poitiers.fr/~maavl/LiEman/manual.pdf
source = lie
source = lie.1
md5sums = 2e98f252364d43557a322ea7eb677944
+ md5sums = 671f912a866faac09d35f549a59d8338
md5sums = d4f5ad8b87479ef93734eee6d1629190
md5sums = a47060395617ed656eaccde1a9e9ee93
diff --git a/.gitignore b/.gitignore
index 3f20c6e06904..0f9fc0954380 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.xz
*.gz
-pkg
-src
+pkg/
+src/
+*.pdf
diff --git a/PKGBUILD b/PKGBUILD
index 070563617a63..2f6c0f1827f3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,17 @@
pkgname=conlie
pkgver=2.2.2
-pkgrel=2
-pkgdesc="A Computer algebra package for Lie group computations"
+pkgrel=3
+pkgdesc="A Computer algebra package for Lie group computations (Compile only version)"
arch=('i686' 'x86_64')
url="http://www-math.univ-poitiers.fr/~maavl/LiE/"
license=('LGPL')
depends=('sh')
-install="$pkgname.install"
-source=("http://www-math.univ-poitiers.fr/~maavl/LiE/conLiE.tar.gz" 'lie' 'lie.1')
+provides=('lie')
+source=("http://www-math.univ-poitiers.fr/~maavl/LiE/conLiE.tar.gz" "http://wwwmathlabo.univ-poitiers.fr/~maavl/LiEman/manual.pdf" 'lie' 'lie.1')
md5sums=('2e98f252364d43557a322ea7eb677944'
- 'd4f5ad8b87479ef93734eee6d1629190'
+ '671f912a866faac09d35f549a59d8338'
+ '469db0e6965f301286ddd052b2cfe96d'
'a47060395617ed656eaccde1a9e9ee93')
build() {
@@ -34,6 +35,7 @@ package() {
done
install -D manual/manual.dvi $pkgdir/usr/share/doc/lie/manual.dvi
+ install -D ../manual.pdf $pkgdir/usr/share/doc/lie/manual.pdf
install -D README $pkgdir/usr/share/doc/lie-2.2.2/README
install -D $srcdir/lie.1 $pkgdir/usr/share/man/man1/lie.1
diff --git a/conlie.install b/conlie.install
deleted file mode 100755
index 843f01a310f2..000000000000
--- a/conlie.install
+++ /dev/null
@@ -1,35 +0,0 @@
-# arg 1: the new package version
-pre_install() {
- /bin/true
-}
-
-# arg 1: the new package version
-post_install() {
- /bin/true
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- /bin/true
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-# arg 1: the old package version
-post_remove() {
- /bin/true
-}
-
-op=$1
-shift
-$op $*
diff --git a/lie b/lie
index 54fa7895ed08..4c1015df9c42 100755
--- a/lie
+++ b/lie
@@ -1,4 +1,2 @@
#!/bin/sh
-PTH=`which ${0} | sed -e 's/bin\/lie//'`
-
-exec ${PTH}/bin/Lie.exe initfile ${PTH}/lib/lie
+exec /usr/bin/Lie.exe initfile /usr/lib/lie