summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD58
2 files changed, 39 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ff88456efab..88623bb6d3e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = copasi-bin
pkgdesc = COmplex PAthway SImulator for analysis of biochemical networks and their dynamics
- pkgver = 4.30.240
+ pkgver = 4.31.243
pkgrel = 1
url = http://www.copasi.org/
install = copasi.install
@@ -9,13 +9,12 @@ pkgbase = copasi-bin
license = Artistic 2.0
depends = shared-mime-info
depends = freetype2
- noextract = copasi-bin-4.30.240.tar.gz
+ noextract = copasi-bin-4.31.243.tar.gz
source = copasi-desktop.tar.gz
sha256sums = 9576e4a9b2c7e74c91d0e1c0b39fcb20531e8fb4f21c5e8ac95b048609702923
- source_i686 = copasi-bin-4.30.240.tar.gz::https://github.com/copasi/COPASI/releases/download/Build-240/COPASI-4.30.240-Linux-32bit.tar.gz
- sha256sums_i686 = d9fa077c260dfafec94c4c205267f61fc12bd0dcaa429bb26f31d2e704e18ce3
- source_x86_64 = copasi-bin-4.30.240.tar.gz::https://github.com/copasi/COPASI/releases/download/Build-240/COPASI-4.30.240-Linux-64bit.tar.gz
- sha256sums_x86_64 = d9fa077c260dfafec94c4c205267f61fc12bd0dcaa429bb26f31d2e704e18ce3
+ source_i686 = copasi-bin-4.31.243.sh::https://github.com/copasi/COPASI/releases/download/Build-243/COPASI-4.31.243-Linux-32bit.sh
+ sha256sums_i686 = d9d08cf72b577b89179a90eaf9604c3c4ede550d2a729bc602f2523b0935be49
+ source_x86_64 = copasi-bin-4.31.243.sh::https://github.com/copasi/COPASI/releases/download/Build-243/COPASI-4.31.243-Linux-64bit.sh
+ sha256sums_x86_64 = d9d08cf72b577b89179a90eaf9604c3c4ede550d2a729bc602f2523b0935be49
pkgname = copasi-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 219f5106839a..f911fa476f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stephen Checkley <scheckley at gmail dot com>
pkgname=copasi-bin
-pkgver=4.30.240
+pkgver=4.31.243
_pkgver=${pkgver##*.}
pkgrel=1
pkgdesc="COmplex PAthway SImulator for analysis of biochemical networks and their dynamics"
@@ -12,33 +12,41 @@ source=('copasi-desktop.tar.gz')
install=copasi.install
noextract=($pkgname-$pkgver.tar.gz)
_source=https://github.com/copasi/COPASI/releases/download/Build-$_pkgver
-source_i686=($pkgname-$pkgver.tar.gz::$_source/COPASI-$pkgver-Linux-32bit.tar.gz)
-source_x86_64=($pkgname-$pkgver.tar.gz::$_source/COPASI-$pkgver-Linux-64bit.tar.gz)
+source_i686=($pkgname-$pkgver.sh::$_source/COPASI-$pkgver-Linux-32bit.sh)
+source_x86_64=($pkgname-$pkgver.sh::$_source/COPASI-$pkgver-Linux-64bit.sh)
sha256sums=('9576e4a9b2c7e74c91d0e1c0b39fcb20531e8fb4f21c5e8ac95b048609702923')
-sha256sums_i686=('d9fa077c260dfafec94c4c205267f61fc12bd0dcaa429bb26f31d2e704e18ce3')
-sha256sums_x86_64=('d9fa077c260dfafec94c4c205267f61fc12bd0dcaa429bb26f31d2e704e18ce3')
+sha256sums_i686=('d9d08cf72b577b89179a90eaf9604c3c4ede550d2a729bc602f2523b0935be49')
+sha256sums_x86_64=('d9d08cf72b577b89179a90eaf9604c3c4ede550d2a729bc602f2523b0935be49')
package() {
- cd "$srcdir"
- tar -xf $pkgname-$pkgver.tar.gz --strip=1
- rm "$srcdir"/share/copasi/lib/libfreetype.so.6
- ln -s /usr/lib/libfreetype.so "$srcdir"/share/copasi/lib/
- ln -s /usr/lib/libfreetype.so.6 "$srcdir"/share/copasi/lib/
+ MACHINE_TYPE=`uname -m`
+ if [ ${MACHINE_TYPE} == 'x86_64' ]; then
+ arch_flag=64bit
+ else
+ arch_flag=32bit
+ fi
+
+ cd "$srcdir"
+ sh $pkgname-$pkgver.sh -e ~/
+
+ rm ~/COPASI-$pkgver-Linux-$arch_flag/share/copasi/lib/libfreetype.so.6
+ ln -s /usr/lib/libfreetype.so ~/COPASI-$pkgver-Linux-$arch_flag/share/copasi/lib/
+ ln -s /usr/lib/libfreetype.so.6 ~/COPASI-$pkgver-Linux-$arch_flag/share/copasi/lib/
+
+ # install program files
+ install -m755 bin/* /usr/bin/
+ cp -R ~/COPASI-$pkgver-Linux-$arch_flag/share/copasi /usr/share/
+
+ # desktop integration...
+ cd "$srcdir"/copasi-desktop
+ install -Dm755 copasi.sh "$pkgdir/etc/profile.d/copasi.sh"
+ install -Dm644 copasi.desktop "$pkgdir/usr/share/applications/copasi.desktop"
+ install -Dm644 copasi.xml "$pkgdir/usr/share/mime/packages/copasi.xml"
+ install -d "$pkgdir/usr/share/icons/hicolor"
+ cp -R icons/* "$pkgdir/usr/share/icons/hicolor/"
+ # copasi starts CopasiUI after setting COPASIDIR environment variable
+ # useful for launching COPASI using the menu entry
+ install -Dm755 copasi "$pkgdir/usr/bin/copasi"
- # install program files
- install -d "$pkgdir"/usr/{bin,share}
- install -m755 bin/* "$pkgdir"/usr/bin
- cp -R share/copasi "$pkgdir"/usr/share/
-
- # desktop integration...
- cd "$srcdir"/copasi-desktop
- install -Dm755 copasi.sh "$pkgdir/etc/profile.d/copasi.sh"
- install -Dm644 copasi.desktop "$pkgdir/usr/share/applications/copasi.desktop"
- install -Dm644 copasi.xml "$pkgdir/usr/share/mime/packages/copasi.xml"
- install -d "$pkgdir/usr/share/icons/hicolor"
- cp -R icons/* "$pkgdir/usr/share/icons/hicolor/"
- # copasi starts CopasiUI after setting COPASIDIR environment variable
- # useful for launching COPASI using the menu entry
- install -Dm755 copasi "$pkgdir/usr/bin/copasi"
}