summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--0001-fix-conflicting-path-in-brightness.patch25
-rw-r--r--PKGBUILD35
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1919af0a22c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = coreaction
+ pkgdesc = A side bar for showing widgets from the CoreApps family.
+ pkgver = 2.7.0
+ pkgrel = 2
+ url = https://gitlab.com/cubocore/coreaction
+ arch = x86_64
+ arch = aarch64
+ groups = coreapps
+ license = GPL3
+ depends = qt5-base
+ depends = libcprime
+ depends = libcsys
+ source = https://gitlab.com/cubocore/coreaction/-/archive/v2.7.0/coreaction-v2.7.0.tar.gz
+ source = 0001-fix-conflicting-path-in-brightness.patch
+ md5sums = b2f80408568abba68a2ef3b92bda9deb
+ md5sums = 9d0bcf2721cbeac7a90f15c8f7ae6f4d
+
+pkgname = coreaction
+
diff --git a/0001-fix-conflicting-path-in-brightness.patch b/0001-fix-conflicting-path-in-brightness.patch
new file mode 100644
index 000000000000..399f78880f54
--- /dev/null
+++ b/0001-fix-conflicting-path-in-brightness.patch
@@ -0,0 +1,25 @@
+From af63a8119c14facf376f1787bd24541c9f2b1a2f Mon Sep 17 00:00:00 2001
+From: Dan Johansen <strit@manjaro.org>
+Date: Fri, 13 Sep 2019 08:20:06 +0200
+Subject: [PATCH] fix conflicting path in brightness
+
+---
+ brightness/brightness.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/brightness/brightness.pro b/brightness/brightness.pro
+index bdd45c7..c69aae2 100644
+--- a/brightness/brightness.pro
++++ b/brightness/brightness.pro
+@@ -31,7 +31,7 @@ unix {
+
+ target.path = $$PREFIX/lib/coreapps/plugins
+
+- udev.path = /lib/udev/rules.d/
++ udev.path = /usr/lib/udev/rules.d/
+ udev.files = 90-coreaction-brightnessctl.rules
+ }
+
+--
+2.23.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd811d1c7457
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Shaber
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+pkgname=coreaction
+pkgver=2.7.0
+pkgrel=2
+pkgdesc="A side bar for showing widgets from the CoreApps family."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/cubocore/$pkgname"
+license=('GPL3')
+depends=('qt5-base' 'libcprime' 'libcsys')
+groups=('coreapps')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+ '0001-fix-conflicting-path-in-brightness.patch')
+md5sums=('b2f80408568abba68a2ef3b92bda9deb'
+ '9d0bcf2721cbeac7a90f15c8f7ae6f4d')
+
+prepare() {
+ cd ${pkgname}-v${pkgver}
+ patch -Np1 -i ../0001-fix-conflicting-path-in-brightness.patch
+ cd ${srcdir}
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}