summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9de59741a2c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = corepack
+ pkgdesc = Zero-runtime-dependency package acting as bridge between Node projects and their package managers.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/nodejs/corepack
+ arch = any
+ license = MIT
+ makedepends = yarn
+ depends = nodejs
+ provides = webtorrent
+ source = 0.9.0.tar.gz::https://github.com/nodejs/corepack/archive/corepack/0.9.0.tar.gz
+ sha256sums = f5fcc80339a251a485a06416f504a97edde1a87b2df3ae5ac88ce773b2d153a7
+
+pkgname = corepack
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3e19ddaa32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Axel Navarro <navarroaxel gmail>
+pkgname=corepack
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Zero-runtime-dependency package acting as bridge between Node projects and their package managers."
+arch=('any')
+url="https://github.com/nodejs/$pkgname"
+license=('MIT')
+depends=('nodejs')
+makedepends=('yarn')
+provides=('webtorrent')
+source=($pkgver.tar.gz::$url/archive/$pkgname/$pkgver.tar.gz)
+sha256sums=('f5fcc80339a251a485a06416f504a97edde1a87b2df3ae5ac88ce773b2d153a7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
+
+ yarn build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
+
+ install -dm755 "$pkgdir/usr/lib/$pkgname"
+ cp -a dist/** "$pkgdir/usr/lib/$pkgname/"
+ chmod +x "${pkgdir}/usr/lib/$pkgname/$pkgname.js"
+
+ install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -d "$pkgdir/usr/bin"
+ ln -s "/usr/lib/$pkgname/$pkgname.js" "$pkgdir/usr/bin/$pkgname"
+}