summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7fcaa741591..f370493dc245 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = corestuff
pkgdesc = An activity viewer from the CoreApps family.
- pkgver = 3.0.1
+ pkgver = 4.0.0
pkgrel = 1
url = https://gitlab.com/cubocore/corestuff
arch = x86_64
arch = aarch64
groups = coreapps
license = GPL3
- makedepends = git
depends = qt5-base
depends = qt5-x11extras
depends = libxcomposite
@@ -15,8 +14,8 @@ pkgbase = corestuff
depends = libcsys>=2.7.1
depends = libcprime>=2.7.1
replaces = corebox
- source = git+https://gitlab.com/cubocore/corestuff.git#tag=v3.0.1
- md5sums = SKIP
+ source = https://gitlab.com/cubocore/corestuff/-/archive/v4.0.0/corestuff-v4.0.0.tar.gz
+ md5sums = 39038ab6435fabaf276107df5254ca36
pkgname = corestuff
diff --git a/PKGBUILD b/PKGBUILD
index 33e9459d99db..55b0d5036502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,27 @@
-# Contributor: Shaber
# Maintainer: Dan Johansen <strit@manjaro.org>
+# Contributor: Shaber
pkgname=corestuff
-pkgver=3.0.1
+pkgver=4.0.0
pkgrel=1
pkgdesc="An activity viewer from the CoreApps family."
arch=('x86_64' 'aarch64')
url="https://gitlab.com/cubocore/$pkgname"
license=('GPL3')
depends=('qt5-base' 'qt5-x11extras' 'libxcomposite' 'kglobalaccel' 'libcsys>=2.7.1' 'libcprime>=2.7.1')
-makedepends=('git')
replaces=('corebox')
groups=('coreapps')
-source=( #"https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
- "git+https://gitlab.com/cubocore/$pkgname.git#tag=v$pkgver")
-md5sums=('SKIP')
-
-prepare() {
- mkdir -p build
- cd ${pkgname}
- git submodule update --init --recursive
-}
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('39038ab6435fabaf276107df5254ca36')
build() {
- cd ${pkgname}
+ cd ${pkgname}-v${pkgver}
qmake-qt5 ${pkgname}.pro
make
}
package() {
- cd ${pkgname}
+ cd ${pkgname}-v${pkgver}
make INSTALL_ROOT=${pkgdir} install
}