summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD55
3 files changed, 44 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7575fddb62c5..24d1f10a9d3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = coreutils-hybrid
pkgdesc = GNU coreutils / uutils-coreutils hybrid package. Uses stable uutils programs mixed with GNU counterparts if uutils counterpart is unfinished / buggy
- pkgver = 8.32_0.0.7
- pkgrel = 2
+ pkgver = 9.4_0.0.25
+ pkgrel = 1
url = https://www.gnu.org/software/coreutils/
arch = x86_64
license = GPL3
license = MIT
makedepends = rust
makedepends = cargo
- makedepends = python-sphinx
depends = glibc
depends = acl
depends = attr
@@ -17,12 +16,10 @@ pkgbase = coreutils-hybrid
depends = openssl
provides = coreutils
conflicts = coreutils
- source = https://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz
- source = https://ftp.gnu.org/gnu/coreutils/coreutils-8.32.tar.xz.sig
- source = uutils-coreutils-0.0.7.tar.gz::https://github.com/uutils/coreutils/archive/0.0.7.tar.gz
- validpgpkeys = 6C37DC12121A5006BC1DB804DF6FD971306037D9
- sha512sums = 1c8f3584efd61b4b02e7ac5db8e103b63cfb2063432caaf1e64cb2dcc56d8c657d1133bbf10bd41468d6a1f31142e6caa81d16ae68fa3e6e84075c253613a145
- sha512sums = SKIP
- sha512sums = 7e91ffdc1a3a560b6778bf7ec78e6c95bb915dafd983476375a9596a6ea18f758409c9ca3cad2840ac8eed1f549ffcb8b1c9aaef18a5d1645a2b6e539375c39f
+ options = !lto
+ source = https://ftp.gnu.org/gnu/coreutils/coreutils-9.4.tar.xz
+ source = uutils-coreutils-0.0.25.tar.gz::https://github.com/uutils/coreutils/archive/0.0.25.tar.gz
+ sha512sums = 7c55ee23b685a0462bbbd118b04d25278c902604a0dcf3bf4f8bf81faa0500dee5a7813cba6f586d676c98e520cafd420f16479619305e94ea6798d8437561f5
+ sha512sums = bdf523120aa72f41b1d3e8e3ab848f55de5ab5bef888ec0b7a5fa90680b461ea9b7012f39c399750fa35b41893d44d1bee7c31ac10b78946b1649198d0b93278
pkgname = coreutils-hybrid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..79de598d097a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 0ef76db57fae..df31866da95f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,10 @@
pkgname=coreutils-hybrid
_pkgname=coreutils
__pkgname=uutils-coreutils
-pkgver=8.32_0.0.7
-_pkgver=8.32
-__pkgver=0.0.7
-pkgrel=2
+_pkgver=9.4
+__pkgver=0.0.25
+pkgver="$_pkgver"_"$__pkgver"
+pkgrel=1
pkgdesc='GNU coreutils / uutils-coreutils hybrid package. Uses stable uutils programs mixed with GNU counterparts if uutils counterpart is unfinished / buggy'
arch=('x86_64')
license=('GPL3' 'MIT')
@@ -19,41 +19,54 @@ _url='https://github.com/uutils/coreutils'
depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
conflicts=('coreutils')
provides=('coreutils')
-makedepends=('rust' 'cargo' 'python-sphinx')
-source=("https://ftp.gnu.org/gnu/$_pkgname/$_pkgname-$_pkgver.tar.xz"{,.sig}
- "$__pkgname-$__pkgver.tar.gz::$_url/archive/$__pkgver.tar.gz")
-validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
-sha512sums=('1c8f3584efd61b4b02e7ac5db8e103b63cfb2063432caaf1e64cb2dcc56d8c657d1133bbf10bd41468d6a1f31142e6caa81d16ae68fa3e6e84075c253613a145'
- 'SKIP'
- '7e91ffdc1a3a560b6778bf7ec78e6c95bb915dafd983476375a9596a6ea18f758409c9ca3cad2840ac8eed1f549ffcb8b1c9aaef18a5d1645a2b6e539375c39f')
+makedepends=('rust' 'cargo')
+options=(!lto)
+source=("https://ftp.gnu.org/gnu/$_pkgname/$_pkgname-$_pkgver.tar.xz"
+ "$__pkgname-$__pkgver.tar.gz::$_url/archive/$__pkgver.tar.gz")
+sha512sums=('7c55ee23b685a0462bbbd118b04d25278c902604a0dcf3bf4f8bf81faa0500dee5a7813cba6f586d676c98e520cafd420f16479619305e94ea6798d8437561f5'
+ 'bdf523120aa72f41b1d3e8e3ab848f55de5ab5bef888ec0b7a5fa90680b461ea9b7012f39c399750fa35b41893d44d1bee7c31ac10b78946b1649198d0b93278')
+
+prepare() {
+ cd $_pkgname-$_pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ echo "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
build() {
# Build GNU coreutils without the stable uutils programs counterparts leaving out: stat, touch, realpath (genfstab broken), ln (no -s option)
cd $_pkgname-$_pkgver
./configure \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --with-openssl \
- --enable-no-install-program="groups,hostname,kill,uptime,arch,base32,base64,basename,cat,chgrp,chmod,chown,chroot,cksum,comm,csplit,cut,dircolors,dirname,du,env,echo,expand,factor,false,fmt,fold,groups,head,hostid,hostname,id,kill,link,logname,mkdir,mkfifo,mknod,mktemp,mv,nice,nl,nohup,nproc,paste,pathk,pinky,printenv,ptx,pwd,readlink,relpath,rm,rmdir,seq,shred,shuf,sleep,stdbuf,sum,sync,tac,tee,timeout,tr,true,truncate,tsort,tty,uname,unexpand,uniq,unlink,uptime,users,who,wc,whoami,yes"
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-openssl \
+ --enable-no-install-program="groups,hostname,kill,uptime,arch,base32,base64,basename,cat,chgrp,chmod,chown,chroot,cksum,comm,csplit,cut,dircolors,dirname,du,env,echo,expand,factor,false,fmt,fold,groups,head,hostid,hostname,id,kill,link,logname,mkdir,mkfifo,mknod,mktemp,mv,nice,nl,nohup,nproc,paste,pathk,pinky,printenv,ptx,pwd,readlink,relpath,rm,rmdir,seq,shred,shuf,sleep,stdbuf,sum,sync,tac,tee,timeout,tr,true,truncate,tsort,tty,uname,unexpand,uniq,unlink,uptime,users,who,wc,whoami,yes"
}
package() {
# Install uutils-coreutils, skip the buggy parts
cd $_pkgname-$__pkgver
make \
- DESTDIR="$pkgdir" \
- PREFIX=/usr \
- MANDIR=/share/man/man1 \
- PROG_PREFIX= \
- install
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ MANDIR=/share/man/man1 \
+ PROG_PREFIX= \
+ install
# Install GNU coreutils over the uutils-coreutils
cd $srcdir && cd $_pkgname-$_pkgver
make DESTDIR="$pkgdir" install
-
+
# Clean conflicts, Arch ships these in other apps
cd $pkgdir/usr/bin
rm groups hostname kill more uptime
rm $pkgdir/usr/share/bash-completion/completions/*
+ rm $pkgdir/usr/share/man/man1/{groups.1,hostname.1,kill.1,more.1,uptime.1}
}