summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbaca7f4d132
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = corosync-qdevice
+ pkgdesc = The Corosync Cluster Engine Qdevice
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://www.corosync.org/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = BSD
+ depends = corosync
+ source = corosync-qdevice-3.0.0.tar.gz::https://github.com/corosync/corosync-qdevice/archive/v3.0.0.tar.gz
+ sha256sums = 06b6ba6bd34186a13e645b962cbcf0ebf644227688e3578e239632c82243ab3c
+
+pkgname = corosync-qdevice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8125850b7f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Patrick Jennings <patrick at jenningsga dot com>
+
+pkgname=corosync-qdevice
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="The Corosync Cluster Engine Qdevice"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://www.corosync.org/"
+license=('BSD')
+depends=('corosync')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/corosync/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('06b6ba6bd34186a13e645b962cbcf0ebf644227688e3578e239632c82243ab3c')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --enable-dbus \
+ --enable-monitoring \
+ --enable-watchdog \
+ --enable-systemd \
+ --disable-upstart \
+ --enable-snmp \
+ --enable-xmlconf \
+ --enable-qdevices \
+ --enable-qnetd \
+ --localstatedir=/var \
+ --with-systemddir=/usr/lib/systemd/system \
+ --with-tmpfilesdir=/usr/lib/tmpfiles.d
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -r "$pkgdir/var/run"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set sw=2 et: