summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-cors-trace2tuple.c-Remove-missing-header.patch24
-rw-r--r--0002-Removes-include-to-config.h-in-public-headers.patch67
-rw-r--r--PKGBUILD12
-rw-r--r--remove-missing-header.patch10
5 files changed, 103 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63e9e5023ce7..3e7bf9049585 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = corsaro
pkgdesc = A software suite for performing large-scale analysis of trace data
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.caida.org/tools/measurement/corsaro/
arch = i686
arch = x86_64
license = GPL2
depends = libtrace
source = https://www.caida.org/tools/measurement/corsaro/downloads/corsaro-2.1.0.tar.gz
- source = remove-missing-header.patch
+ source = 0001-cors-trace2tuple.c-Remove-missing-header.patch
+ source = 0002-Removes-include-to-config.h-in-public-headers.patch
md5sums = f4970360525b5d112a1040a27503e87f
- md5sums = f0b86fa23f427c9a0ba608e7a1b5081d
+ md5sums = 4ea8f2e5a1bd608e8a65e8f7dbd9a2f8
+ md5sums = 440716d2539a211ad4105d4ff7bac9b1
pkgname = corsaro
diff --git a/0001-cors-trace2tuple.c-Remove-missing-header.patch b/0001-cors-trace2tuple.c-Remove-missing-header.patch
new file mode 100644
index 000000000000..8996df6a47e8
--- /dev/null
+++ b/0001-cors-trace2tuple.c-Remove-missing-header.patch
@@ -0,0 +1,24 @@
+From 546204cc77b7299637ea16ff470921d43e4bc1a5 Mon Sep 17 00:00:00 2001
+From: Mark Weiman <mweiman@merit.edu>
+Date: Fri, 12 Oct 2018 09:45:28 -0400
+Subject: [PATCH 1/2] cors-trace2tuple.c: Remove missing header
+
+---
+ tools/cors-trace2tuple.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/tools/cors-trace2tuple.c b/tools/cors-trace2tuple.c
+index cacae27..ea36c19 100644
+--- a/tools/cors-trace2tuple.c
++++ b/tools/cors-trace2tuple.c
+@@ -58,7 +58,6 @@
+ #include <signal.h>
+
+ #include "libtrace.h"
+-#include "lt_inttypes.h"
+
+ struct libtrace_t *trace;
+
+--
+2.19.1
+
diff --git a/0002-Removes-include-to-config.h-in-public-headers.patch b/0002-Removes-include-to-config.h-in-public-headers.patch
new file mode 100644
index 000000000000..e1a9e0187c9a
--- /dev/null
+++ b/0002-Removes-include-to-config.h-in-public-headers.patch
@@ -0,0 +1,67 @@
+From 40120246db7ab08b34a800234f97a66d42f5c8de Mon Sep 17 00:00:00 2001
+From: Mark Weiman <mweiman@merit.edu>
+Date: Fri, 12 Oct 2018 10:04:52 -0400
+Subject: [PATCH 2/2] Removes include to config.h in public headers
+
+---
+ libcorsaro/corsaro.h | 2 --
+ libcorsaro/corsaro_io.h | 2 --
+ libcorsaro/corsaro_log.h | 2 --
+ tools/cors-ft-aggregate.c | 2 ++
+ 4 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/libcorsaro/corsaro.h b/libcorsaro/corsaro.h
+index 43ee02d..642edb8 100644
+--- a/libcorsaro/corsaro.h
++++ b/libcorsaro/corsaro.h
+@@ -26,8 +26,6 @@
+ #ifndef __CORSARO_H
+ #define __CORSARO_H
+
+-#include "config.h"
+-
+ #include "libtrace.h"
+ #include "wandio.h"
+
+diff --git a/libcorsaro/corsaro_io.h b/libcorsaro/corsaro_io.h
+index 0984707..bd7a72b 100644
+--- a/libcorsaro/corsaro_io.h
++++ b/libcorsaro/corsaro_io.h
+@@ -26,8 +26,6 @@
+ #ifndef __CORSARO_IO_H
+ #define __CORSARO_IO_H
+
+-#include "config.h"
+-
+ #include "corsaro_int.h"
+
+ #include "corsaro_file.h"
+diff --git a/libcorsaro/corsaro_log.h b/libcorsaro/corsaro_log.h
+index 6ebc4e3..d3d6d60 100644
+--- a/libcorsaro/corsaro_log.h
++++ b/libcorsaro/corsaro_log.h
+@@ -26,8 +26,6 @@
+ #ifndef __CORSARO_LOG_H
+ #define __CORSARO_LOG_H
+
+-#include "config.h"
+-
+ #include <stdarg.h>
+
+ #include "corsaro_int.h"
+diff --git a/tools/cors-ft-aggregate.c b/tools/cors-ft-aggregate.c
+index 471b48e..c6f1bd1 100644
+--- a/tools/cors-ft-aggregate.c
++++ b/tools/cors-ft-aggregate.c
+@@ -30,6 +30,8 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#include "config.h"
++
+ #include "libtrace.h"
+
+ #include "corsaro.h"
+--
+2.19.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 7f827094a711..c29668fa2ea7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
pkgname=corsaro
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A software suite for performing large-scale analysis of trace data"
arch=('i686' 'x86_64')
url="https://www.caida.org/tools/measurement/corsaro/"
depends=('libtrace')
license=('GPL2')
source=("https://www.caida.org/tools/measurement/${pkgname}/downloads/${pkgname}-${pkgver}.tar.gz"
- remove-missing-header.patch)
+ 0001-cors-trace2tuple.c-Remove-missing-header.patch
+ 0002-Removes-include-to-config.h-in-public-headers.patch)
md5sums=('f4970360525b5d112a1040a27503e87f'
- 'f0b86fa23f427c9a0ba608e7a1b5081d')
+ '4ea8f2e5a1bd608e8a65e8f7dbd9a2f8'
+ '440716d2539a211ad4105d4ff7bac9b1')
build() {
cd "${pkgname}-${pkgver}"
- msg "Applying remove-missing-header.patch"
- patch -Np0 -i ../remove-missing-header.patch
+ patch -p1 -i ../0001-cors-trace2tuple.c-Remove-missing-header.patch
+ patch -p1 -i ../0002-Removes-include-to-config.h-in-public-headers.patch
./configure --prefix=/usr
make
diff --git a/remove-missing-header.patch b/remove-missing-header.patch
deleted file mode 100644
index 8710907e3454..000000000000
--- a/remove-missing-header.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/cors-trace2tuple.c.old 2018-10-04 15:06:42.729321143 -0400
-+++ tools/cors-trace2tuple.c 2018-10-04 15:06:59.982931558 -0400
-@@ -58,7 +58,6 @@
- #include <signal.h>
-
- #include "libtrace.h"
--#include "lt_inttypes.h"
-
- struct libtrace_t *trace;
-