summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--bin3
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27c376031b74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = corsix-th
+ pkgdesc = Reimplementation of the game engine of Theme Hospital
+ pkgver = 0.40
+ pkgrel = 1
+ url = https://github.com/CorsixTH/CorsixTH/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = cmake
+ depends = lua51
+ depends = sdl_mixer
+ depends = ffmpeg
+ depends = timidity-freepats
+ source = https://github.com/CorsixTH/CorsixTH/archive/v0.40.tar.gz
+ source = bin
+ sha1sums = 2e88e319f8c73e83068c8db08f1598cc097b2b27
+ sha1sums = 7fd6ae8db366b7f9c4671708e8ea7beb48f1bea3
+
+pkgname = corsix-th
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb8d186db9aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=corsix-th
+pkgver=0.40
+pkgrel=1
+pkgdesc='Reimplementation of the game engine of Theme Hospital'
+url='https://github.com/CorsixTH/CorsixTH/'
+arch=('i686' 'x86_64' 'armv7h')
+license=('MIT')
+makedepends=('cmake')
+depends=('lua51' 'sdl_mixer' 'ffmpeg' 'timidity-freepats')
+source=("${url}archive/v${pkgver}.tar.gz"
+ 'bin')
+sha1sums=('2e88e319f8c73e83068c8db08f1598cc097b2b27'
+ '7fd6ae8db366b7f9c4671708e8ea7beb48f1bea3')
+
+# If you do not have a copy of Theme Hospital,
+# you can download the data files of the demo:
+# http://th.corsix.org/Demo.zip
+
+build() {
+ cd "${srcdir}/CorsixTH-${pkgver}"
+ cmake \
+ -D LUA_INCLUDE_DIR=/usr/include/lua5.1 \
+ -D LUA_LIBRARY=/usr/lib/liblua5.1.so \
+ -D CMAKE_INSTALL_PREFIX=/usr/share/ \
+ -D CMAKE_BUILD_TYPE=Release \
+ -Wno-dev .
+ cd CorsixTH
+ make
+}
+
+package() {
+ cd "${srcdir}/CorsixTH-${pkgver}/CorsixTH"
+ make DESTDIR="${pkgdir}" install
+ install -Dm755 ../../bin "${pkgdir}/usr/bin/CorsixTH"
+ install -Dm644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 ../DebianPackage/usr/share/applications/CorsixTH.desktop "${pkgdir}/usr/share/applications/CorsixTH.desktop"
+ sed -e 's/games/share/g' -i "${pkgdir}/usr/share/applications/CorsixTH.desktop"
+}
diff --git a/bin b/bin
new file mode 100644
index 000000000000..545bab32e5d6
--- /dev/null
+++ b/bin
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/share/CorsixTH/CorsixTH