summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 5 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 479e6017602d..960380ccf04b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = corsix-th-git
pkgdesc = Reimplementation of the game engine of Theme Hospital, git version
- pkgver = 0.62.r98.g4e6c9854
+ pkgver = 0.64.r10.gb7abdd01
pkgrel = 1
url = https://github.com/CorsixTH/CorsixTH
install = corsix-th.install
@@ -18,11 +18,7 @@ pkgbase = corsix-th-git
provides = corsix-th
conflicts = corsix-th
source = git+https://github.com/CorsixTH/CorsixTH.git
- source = CorsixTH.desktop
- source = corsix-th.sh
sha256sums = SKIP
- sha256sums = 84568693506b208bf3d4cc60f1e830e9e1b236b6cd7032a24437f06176aa57f8
- sha256sums = 3614197a30498774fff4055ee54d82a812a8b88eba353b70c3288a09ff700158
pkgname = corsix-th-git
diff --git a/PKGBUILD b/PKGBUILD
index be10eb687345..54d57ea4b6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,5 @@
-#original package by:
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributor: Gaetan Bisson <bisson@archlinux.org>
-# Contributors: jdc, rayman2200
-
pkgname=corsix-th-git
-pkgver=0.62.r98.g4e6c9854
+pkgver=0.64.r10.gb7abdd01
pkgrel=1
pkgdesc='Reimplementation of the game engine of Theme Hospital, git version'
url='https://github.com/CorsixTH/CorsixTH'
@@ -15,14 +10,9 @@ provides=('corsix-th')
conflicts=('corsix-th')
depends=('lua' 'lua-lpeg' 'lua-filesystem' 'sdl2_mixer' 'ffmpeg' 'freepats-general-midi')
install=corsix-th.install
-source=("git+https://github.com/CorsixTH/CorsixTH.git"
- "CorsixTH.desktop"
- "corsix-th.sh")
-
-sha256sums=('SKIP'
- '84568693506b208bf3d4cc60f1e830e9e1b236b6cd7032a24437f06176aa57f8'
- '3614197a30498774fff4055ee54d82a812a8b88eba353b70c3288a09ff700158')
+source=("git+https://github.com/CorsixTH/CorsixTH.git")
+sha256sums=('SKIP')
pkgver() {
cd "CorsixTH"
@@ -34,17 +24,11 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release -Wno-dev \
-DLUA_PROGRAM_PATH=/usr/bin/lua -DLUA_INCLUDE_DIR=/usr/include -DLUA_LIBRARY=/usr/lib/liblua.so \
- -DCMAKE_INSTALL_PREFIX=/usr/share/ .
+ -DCMAKE_INSTALL_PREFIX=/usr .
cd CorsixTH
make
}
package() {
make -C CorsixTH/CorsixTH DESTDIR="$pkgdir/" install
- # launcher
- install -Dm0755 corsix-th.sh "$pkgdir"/usr/bin/CorsixTH
- # license
- install -Dm0644 CorsixTH/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- # .desktop integration
- install -Dm0644 CorsixTH.desktop "$pkgdir"/usr/share/applications/CorsixTH.desktop
}